Rockstor stopped working

After a power failure and a shutdown, rockstor is not booting up. It gets stuck with the following error.
I tried rescue as well, same issue.

Tested the original install stick for rockstor I used to install.
This one works just fine.

I am using a HP NL40 with an SSD as system and 4 additional drives.
Also tried to remove the disks, except the system SSD, nothing changed.

what happend how can I fix this without loosing data and rock-ons :slight_smile:

is efi boot on by any chance?
have some graphics related settings changed?
has the bios reset some settings?

the first line seems to be related to some ahci protocol error, but it could be something else too.
the second line seems to be graphics related, but it could be something else too.

I have seen the first line before and machines usually boot up despite the message. I have not seen the second message before. You could also edit the grub entry and remove all parameters after crashkernel=auto. That may display errors more elaborately.

Another thing to try is to boot up with other kernels from the menu.

I gonna try a few of your things today.
Still, what makes me suspicious is, that the usb stick with the rockstor installation routing is working on the system without any problems.

I also have no chance to change kernel, there is only one on my system at the moment :smiley: besides the rescue kernel, which has the same problem.

Therefor I think, it has something to do with the system itself, if installation from usb stick starts without issues.

Is it possible to reinstall rockstor without losing data. :smiley:

@herbert Just a quick post re reinstalling. There is a Reinstalling Rockstor HowTo in the docs/manual.
As long as you haven’t used the rockstor_rockstor pool for any anything then your data should be good. Might be advisable to disconnect your data drives before the install just to be sure. Settings wise you would need to have made a configuration backup.

As for those kernel messages I believe they are a red herring although @suman 's suggestion would be good to find out more. The i8042 is the name for the original keyboard controller chip on IBM PC’s.

An excert from my dmesg on a Rockstor system is:-

[    1.002809] usbserial: USB Serial support registered for generic
[    1.002829] usbcore: registered new interface driver wishbone_serial
[    1.002842] usbserial: USB Serial support registered for wishbone_serial
[    1.002899] i8042: PNP: No PS/2 controller found. Probing ports directly.
[    1.005639] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.005652] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.005930] mousedev: PS/2 mouse device common for all mice
[    1.006402] rtc_cmos 00:00: RTC can wake from S4
[    1.006663] rtc_cmos 00:00: rtc core: registered rtc_cmos as rtc0

Not sure if this will help but only time for a fly by post I’m afraid.

All I can suggest is to work backward and pay attention to the changes you made hardware wise prior to this boot failure.

Please let us / the forum know how you get on. As you say it’s quite strange, especially given how early it is in the boot.


because of the error which I didn’t understand, all live ISOs I tested worked like a charm, also the rockstor iso. Therefor I took a pretty radical approach which seems to work now.
I resetted the BIOS, I have not changed anything in the BIOS since rockstor is running but I thought, why not.

Now it boots, lets see for how long. I keep this thread alive, because I do know my magic fingers, I do need the post pretty soon again :slight_smile:

1 Like