Rockstor VM doesn't boot when using OMVF (UEFI)

Hi all,

I am currently trying to deploy a Rockstor VM on my Proxmox Hypervisor. When I tried it out using the Seabios instead of OMVF UUEFI, everything went as expected, I installed the vm withour a problem and the system booted without a hitch.

For the productive system I want to switch to OMVF, as I use it for all my VMs. The installaltion worked without a problem and I restarted the VM. When it boots, I can select which Kernel I want to boot, I left in on the default one and waited for it to boot.
The problem is, it gets stuck on a black screen with a single text cursor, but it’s not starting the boot procedure nor can I enter anything.
Here is a picture (even though it doesn’t show much at all:

Is this a known problem or is there a workaround to get it to work?
I tried different types of disks (VirtIO, SCSI, SATA), but it doesn’t change the outcome.

Kind regards,

Hi @JannikJung0 and welcome to Rockstor community!

First point: your “issue” isn’t strictly related to Rockstor (Proxmox)
Second point: I ran Rockstor on Proxmox too :wink: but always with Seabios

Suggestion: tomorrow I’ll check it

Once again, welcome on board

Hi @Flyer,

thanks for your fast reply!

That’s true, could very well be an issue with Proxmox as well, but I never had a problem like this with any of my other OMVF VMs, so I thought I’ll ask here first.

I’m currently running Rockstor with Seabios as well, which works without a problem.
I also didn’t accounter any problems with the VirtIO Disks.

Great, let me know if you encounter any problems!
I’m running a fully up-to-date proxmox installation and downloaded Rockstor yesterday (Version: 3.8.15)

Thank you very much!

Hey Flyer,

did you find some time to test it and were you able to reproduce my problem?

Kind regards,

Hi @JannikJung0,
not yet, actually “having fun” trying to get Mac OS X running in Win VirtualBox (there’s an open issue on Rockstor Dashboard on Macs) :angry:

Will do asap