Rockstor won't finish booting after 2016-04-19 update

Hi all,

Rockstor won’t finish booting after I updated it on 2016-04-19. I tried to diagnose it myself and I think it might be related to a recent commit 8b573ff7627c264d912048c712b5dc114594f108.

Any help is appreciated. Let me know if you need more information.

2016-04-19 22:56:37,619: Supported kernel(/boot/vmlinuz-4.4.5-1.el7.elrepo.x86_64) is already the default
2016-04-19 22:56:37,823: Registered task: fs.btrfs.start_balance
2016-04-19 22:57:36,062: Waited too long and tried too many times. Quiting.
Traceback (most recent call last):
File “/opt/rockstor/bin/initrock”, line 43, in
File “/opt/rockstor/src/rockstor/scripts/”, line 332, in main
raise e
smart_manager.models.service.DoesNotExist: Service matching query does not exist.

I am guessing you updated to .12? This should be fixed in .13. You can get it by running yum update. If my guess is correct, you’ve updated in the narrow window during which .13 was being built. sorry about that.

yum update seems to have fixed the problem. I think you’re right, I must have updated in the narrow window when it was being built. Thanks for the help!