Rockstor wont install [Solved]

I am starting to get a little frustrated…

After having experimented with RockStor on a buggy Gigabyte board, I was looking forward to install it on My ASUS M3A78-CM which has proven a rock solid board with my previous (Windows) installs.

But RockStor refuses to install on it. I get through the whole install process onto the point where RockStor install says “Installing bootloader”, after a couple minutes this fails with a message about an unknown error has occured. Why on earth would this fail? The installer has spent the last 10 minutes copying files to the drive, with no complaints, and then fails at the very last step. Annoying.
On the Gigabyte, which is basically the same hardware/chipset the install worked every time.

What could be wrong? I have tried every single BIOS setting there is, and the BIOS is the latest one available for the board.

BTW, Freenas install went smooth without problems on the same board, so the board works OK. But I would rather use RockStor (because of its greater felxibility about adding / removing disks). But it seems that is out of the question.

@KarstenV Yes very frustrating. And quite perplexing as Freenas (at least more recent versions) also uses the same boot loader ie Grub. When in doubt; more information. I know it’s a drag but try a vanilla CentOS 7 install then we can narrow it down a tad. All I can think is some kind of difference between how Freenas (nanobsd) and Rockstor/CentOS (linux) are installing the Grub. Now Grub has UEFI capabilities and in linux that is very common these days but not so in BSD so it may be that the grub install in Freenas is forcing non UEFI mode and maybe something in the Rockstor/CentOS7 install is sensing UEFI and having a go at a UEFI grub install and failing.
Anyway getting a bit ahead of ourselves so:-
Is the board UEFI capable, in which case look to what ASUS call their CSM module and legacy / compatibility stuff to play safe.
Try the vanilla CentOS 7 install as that is pretty much what the Rockstor install is.
Hopefully then something will come to light.

I don’t think what is a fairly generic linux install is going to be out of the question though, this would be a great one to get to the bottom of as it is currently rather a show stopper.

See how you get on. Also other linux distros may be more or less helpful with explaining what might be the problem (if they run into the same that is), they all pretty much use Grub these days so that’s a potential other source of information, ie a quick Ubuntu 15.04 install say; it might bring something to light that we can add to our doc to help future installers. Google wise if the same thing happens on CentOS 7 then we should have potentially a lot of targets.

@phillxnet

Thanks for the reply.

I will use this weekend to try and do the things you detailed.

The board is not UEFI capable.

I have actually never had any problems with it, in any configuration, so I was a little surprised to see the install fail (repeatedly).

I will just add, that this is the board that will serve my up and comming NAS.
So if RockStor ends up not being able to work, I will use another distribution, no matter how much I like RockStor and this support forum :smile:

I have to go to work now, will continue later in the day.

@KarstenV Having slept on it I have another more specific idea which I think you should try first. A frequent forum contributor @sirhcjw in a recent post improved their instability problems by adding the kernel parameter acpi=off. They were also on older hardware. Please read their and my comment on that post for context. As I read their snippet of logs it would seem interrupts were not properly configured and a knockon of this was that the kernel was failing to communicate reliably with the drive controller (and potentially many other things hence my recommendation there after to simply their system) as a result the kernel was continually resetting the drive controller to try to rectify the problem which would in turn result in the drive subsystem intermittently becoming unresponsive / unavailable. Now during install this may well have been happening (the install log would have evidence of this) but may not have caused enough disruption to fail the majority of the install. The majority of the install is simple rpm execution. However if this happened during the grub install then we are dealing with grubs own install timeouts rather than the more generic and I suspect more lenient rpm timeouts. Also note that in the snippet of logs on the referenced post there are repeated:-

lines. The regular rpm subsystem doesn’t work at this level and will just wait for things to settle and access the filesystem when it finally re-appears. But the Grub installer specifically accesses the drive at a low level, and in fact wants to access (among other areas) sector 0 or there abouts. So to me this looks promising and worth a try, especially since it’s quick and has parallels to your circumstance.

To implement you need to:-

- Press the "Tab" key on initial install screen.
- Add to the white text that appears at the bottom of the screen the following:-
- acpi=off
- while you are at it you could remove (its one long line word wrapped) the "quiet" entry

Your should then have something like:-

- then just press the enter key and install

Fingers crossed you may be away.
Rockstor uses one of the most current kernels of any linux distribution so that it can track / implement the new technologies of btrfs so the time distance between its kernel and your hardware is likely to be bigger than on any other distribution. Having said that the installer actually uses a much older kernel that is standard to CentOS 7, it is after all a customized CentOS 7 installer / system. Now upon first reboot after install you will hopefully be running a newer kernel that may suffer from the same incompatibility to a varying extend. The acpi=off that you issued to the install kernel will not be issued to the installed systems kernel. For this you will have to follow the directions given in the same forum post as previously referenced and edit your installed /etc/default/grub to include acpi=off. Hopefully your system is stable enough to get this done. A reboot will be required for the edited grub kernel parameters to take effect though.

  • The quiet kernel parameter is to reduce the text output during boot; but it might tell us something hence removing it.

  • acpi incidentally is short for Advance Configuration and Power Interface
    Hence if not working properly we have a misconfiguration. Turning it off will force the kernel to use older methods to setup the hardware that in the case of older hardware may be more successful.

  • There is of course sometimes no getting round incompatible hardware and if this is the case then you will of course have to use another distro / OS, or use compatible hardware. Many manufacturers for many years paid less heed to standards and more simply to MS OS compatibility; this obviously does not serve well other OS’s, ie searching acpi and freebsd shows multiple references to older hardware requiring Freebsd’s equivalent of “hint.acpi.0.disabled=1”

1 Like

@phillxnet

Thanks again.

I’m not at home to test this out yet, but will be shortly.

The BIOS has an option to turn ACPI off, would this do the trick, or does the installer override this as soon as it knows the hardware capabilities?

Anyway I will try your suggestions.

Your research seems very likely to could be the cause. Will look forward to testing.

Thanks a lot for the time you put into this.

And the hardware can’t be completely incompatible, as the other board I have tested has the same northbridge (780G on the Gigabyte and 780V on the ASUS (which are the same, except for some graphics differences)) and more importantly the same model southbridge (SB700), and on this board the install worked every time. But perhaps this board has ACPI turned of pr. default? One cannot know.

@KarstenV Sorry don’t know the interplay between Bios switch and Kernel switch; as you indicate it might be that even if off the kernel may still have a go. My guess is that if this BIOS switch is off then the board will effectively not have acpi but I don’t know. The ASUS user manual has the following entries:-

  • 2.5.2 ACPI Support [Disabled]
    Allows you to add more tables for Advanced Configuration and Power Interface (ACPI) 2.0
    specifications. Configuration options: [Disabled] [Enabled]

  • 2.5.3 ACPI APIC Support [Enabled]
    Allows you to enable or disable the Advanced Configuration and Power Interface (ACPI)
    support in the Application-Specific Integrated Circuit (ASIC). When set to Enabled, the ACPI
    APIC table pointer is included in the RSDT pointer list. Configuration options: [Disabled]
    [Enabled]

But this does’t tell us about the interplay and doesn’t look like a whole sale disable either. Since it’s such an easy option I say try this first as will be an easier workaround to pass on to others if it works.

The chips themselves can be utilised differently on different motherboards and in concert with the firmware of the board may have different elements exposed. But yes I think there is hope and looks like quite a nice board. Only SATA 2 though but nice it’s got 6 of them (released in 2008-2009 looks like).

1 Like

@phillxnet

I am at home now and have been working on the system.

I turned off “ACPI 2.0 Support” and “ACPI APIC Support” in Power options in the BIOS.
Then rebooted the system, and let Rockstor install, without changing anything during setup.

The setup completed without errors first time around, and the NAS is booted, and upgrading to the latest release.

So it is the ACPI options doing the “harm”.

I also find it a nice board, despite its age, a winning grace is the 6 Sata slots. Yes they are only SATA2, but few mechanical hard disks, if any, can use the bandwith of SATA2. And I’m planning on using slow rotating disks in the system, so I dont think the SATA 2 will set a limit.
And the processors available for the board are still plenty powerfull for basic NAS use, I don’t think my Phenom 940 will have any problems doing the job, and I even plan to let it run at a lower clock-speed, as 4x3GHz is probably a little overkill for my usage.

I received 2x4GB mem today for this system, and installed them. They seem to work perfectly allthough the manual states that the board only accepts mem of up to 2 GB for each memory slot. But the system boots and report 8Gb mem. It wont boot with 10GB mem though, but the manual states that 8GB is the max, so Ill have to live with it :smile:

I am waiting for a PCI-E mSATA adapter, and a 16GB mSATA SSD, which I hope to get working, so I can install RockStor on the SSD, and then use all 6 SATA ports for hard disks. The mSATA adapter also provides an ekstra SATA port, so if it works, I’ll have the possibility of 7 SATA disks at once, which i might end up using :smile:

Well, completely turning off ACPI, effectively turned my Quad core CPU into a single core CPU.

I have enabled “ACPI APIC Support” again, and it seems to work well for now, and all 4 cores are available.

I’ll try this setup for some time, and see if its stable.

Very nice! I hope you won’t run into any more low level issues. Please feel free to share a picture of your setup. It’s not soon enough for you, but we’ll soon be offering PCIe and mSATA accessories in our shop soon.

1 Like

@KarstenV That’s great news, well done. Thanks for sharing your findings, funny about the one core though; so one core note enough for you :smile:. Sounds like this is shaping up to be quite a nice system. I have a couple of those pci-e to mSATA plus SATA adapters myself for use with Rockstor and I believe @suman is soon to offer them on the Rockstor Shop under DIY Accessories which would be dandy.

Do you have any good suggestions / experience case wise as that would be another nice resource to build up. The build-in removable drive caddy types all seem quite expensive, hopefully as diy nas stuff grows in popularity we will get more choice.

Are I see @Suman has just posted some of what I already typed, never mind.

@phillxnet

I have been thinking a lot about what to do regarding to a case to install it all in.

Its not easy, and the products available are either not very good, or good but expensive.

So for now I have decided to build my own version of an open testbed, like the ones many review sites use.

It basically consist of two planks of painted wood, 30x60 cm, and 4 peices of metal to make the one plank “hover” about 20 cm above the other. The top plank will be removeable.

On the lower plank I plan to mount the motherboard and the PSU. Perhaps add a fan to make airflow if that becomes a problem, but I don’t expect it to be.

On the upper board the hard drives will reside.
I’m putting them into some hard-drive cases that came with my Antec P300 case. They are not all that elegant, but they have a nice mounting system with rubber insulators, that dampens vibrations very well. At the end of each HDD case, I’m putting a fan, to make airflow and cool the disks.

A hole will be drilled in the upper plank for the SATA and power cables to go through.

I’m considering making a third plank, and using it as sort of a “lid”.

Those are my plans.

@suman
Maybe someday in the future when I have a more finished build I’ll post some pictures.

@KarstenV That sounds like a great idea. I’m always a little concerned with a lack of shielding in such arrangements but that’s going to look great.

Just tried a reinstall with only “ACPI 2.0 Support” turned of, and it went very well.

So we found the culpritt. Perhaps something to put into the documentation for users installing on older hardware?

@KarstenV Thanks for experimenting and yes the older hardware does present a different kind of a challenge and a collection of things to try would be good. It’s all getting there, bit by bit.

@suman

I actually tried to order some T-shirts the other day, as I need some, and I like RockStor and would like to support it, without it being a donation.

After having chosen the goods, and putting in my adress etc, I got a message that “There are no shipping methods available for your cart or destination”.

So basically I couldnt finish the order.

Is this something you could look into? I live in Denmark.

@KarstenV Thanks for your support, I’d be happy to send you some T-shirts. I just setup international shipping on the shop and tested an order to Copenhagen. It would be through USPS First-class international shipping method. Please try again and let me know if you run into any problems and thanks for alerting me.

Also, it may not be clear when you order, but there’s free shipping for orders over USD 50 to Europe.

@suman

Thank you very much.

I just placed an order for 3 T-shirts, and payed with my card.

The order went straight through, and I received a confirmation mail seconds later.

Earlier today i made an order, which I tried to pay through Paypal, only to see it fail at the shipping (after telling Paypal to pay). I’ll keep an eye out to see how Paypal handles this :smile:

1 Like

Just a follow up, completely off-topic.

Received the T-Shirts today. Fast delivery, I must say :smile:

They look very nice, and I will proudly be wearing them on my comming vacation to Cyprus!

1 Like