Samba shares not seen in windows

Hello everyone…

I’m new to Rockstor and NAS but have a lot of computer experience from mainframes to windows. Self taught in Linux (not very much).

I have sharing setup correctly I believe but in windows when I try to setup the share it does not come up under network however if I put in \server address\sharename it connects and all is well. Why am I not seeing the share in Network?

Have read all the posts I could find and here is some info.

net rpc share list -U Steve
Password for [KAUFMAN-HOME\Steve]:
Vault:~ # testparm /etc/samba/smb.conf
Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
Weak crypto is allowed


Press enter to see a dump of your service definitions

Global parameters

load printers = No
log file = /var/log/samba/log.%m
map to guest = Bad User
printcap name = /dev/null
workgroup = KAUFMAN-HOME
idmap config * : backend = tdb
cups options = raw

admin users = Admin root
comment = Samba-Export
path = /mnt2/testing
read only = No
root preexec = “/opt/rockstor/.venv/bin/mnt-share testing”
root preexec close = Yes
Password for [KAUFMAN-HOME\Steve]:

testing is the share and Steve the user. Windows is V10 and Workgroup is the same on the windows machine.

Share info

Created on: June 10th 2024, 5:10:04 pm
Pool (Active mount options / Status): Test (rw,relatime,space_cache,subvolid=5,subvol=/)
Pool Quotas: Enabled
Active mount options / Status: rw,relatime,space_cache,subvolid=257,subvol=/testing

Space free - 1,023.98 MBSpace used - 16.00 KBSize 1.00 GB

Access control

Owner root
Group root
Owner Group Other

TIA Steve

This might be related to the wsdd service needed to expose the shares in window’s network neighborhood. There is a Rockon for that. Try to install that one and see whether your smb shares show up in windows.


Thanks but that did not help. It has the same thing on my desktoop (win10) and my laptop (Win11).

I do not see the device at all but can connect if I put in addr/sharename.

Could you share the settings you’ve used for the Rockon? I currently don’t have access to my system, but will try to check later.

1 Like

I’m not sure what settings your referring to, I just loaded the Rockon that someone suggested. It did not have any settings.

I assume, you populated the two variables in the wsdd Rockon config screen with something like this (don’t know what your host name, so I just made one up for illustration purposes).


Sorry I forgot about those. Yes I did. Still playing with this. No success. I’m also having a win 10 problem exactly the same. Cannot see either host in Network.

Host=vault and WG as above.

Tomorrow I can share my settings probably.

Here are my settings:

cups options = raw
load printers = no
log file = /var/log/samba/log.%m
log level = 3
map to guest = Bad User
printcap name = /dev/null

domain master = yes
fruit:delete_empty_adfiles = yes
fruit:metadata = stream
fruit:model = MacSamba
fruit:nfs_aces = no
fruit:posix_rename = yes
fruit:veto_appledouble = no
fruit:wipe_intentionally_left_blank_rfork = yes
local master = yes
min protocol = SMB2
netbios name = ROCKSTORHOST_NAME
os level = 255
preferred master = yes
vfs objects = catia fruit streams_xattr
workgroup = HOME_WORKGROUP

root preexec = “/opt/rockstor/.venv/bin/mnt-share testing”
root preexec close = yes
comment = Testing Files
path = /mnt2/testing
browseable = yes
read only = no
guest ok = no
admin users = admin testing

As you can see, within Rockstor global I maintained a few parameter through the services menu. For a given share I don’t have any additional parameters beyond what Rockstor populates automatically. The global vfs and fruit related settings are for apple-specific things (ability to use iphone/ipad to access and manage file shares on the server, I also put a How-To on the forum for that).
Some of the global entries are “legacy” like the netbios name, but I never removed them after windows 10/11 defaulted to using wsdd and SMBv1 was disabled.

Anyway, with these settings I can see the shares on both Windows 11 and 10 machines. I don’t have the win 10 box running so I can’t tell you right now what the settings are but on win11 I have the SMB Direct selected under the windows features:


I had the SMB 1.0 installed and the SMB direct so I removed the SMB1 and no difference. Everything works still but I still can’t see my nas nor can I see my win 10 box that I mad the change on.

I’m on to other things as I can get to the shares directly. I give up on this one.

1 Like