SMB does not show the name but only the IP

Brief description of the problem

I’m a newbie for Rockstor, I previously used Freenas. After installing it I try to make a SMB service so I create a share, activate the service and configured as well. If I try to reach from windows 10 computer I have a problem in certain situation.

Detailed step by step instructions to reproduce the problem

If I use only the ip address (\ I can access with no problem at all but if I used the name (\apollo01) I can’t access. Search on this forum I find some settings to put on the Samba service and I put them without success…what can I do?

Web-UI screenshot


@pinguinone Welcome to the Rockstor community.

This may be a consequence of your local networks inability to resolve name to IP, other than through netbios means, i.e. can your Rockstor system ping the server name you are using: i.e. what is the result of:

ping apollo01

run in a Rockstor terminal.

Also it would help to know the version of Rockstor you are running as there have been many updates over the years, some of which may have helped with this. For example in later versions we now run avahi which may have helped in this case. I’m unfortunately not the samba person on the team as it were but just wanted to chip in with a welcome and to get a little more info on the Rockstor version you are experiencing this with.

Hope that helps. And hopefully those more familiar with this type of custom config can also chip in. And if you have now made custom modifications to the smb.conf then it would be best to published them here to help others with guiding you better than I am able to now.

1 Like

@phillxnet thanks for your prompt response.
Straight to your answer:

  1. As you can see here the result of the ping apollo01 is that:

    Just by this test perhaps I understand where is the problem but I don’t know how to solve that :frowning_face:
    Infact if I go to “System → network” I find out 3 network card on this machine. 1 is disabled and the other 2 has this IP: & The first one is the one that the DNS resolve for apolllo01 so…it could be that Rockstor instead of that had associated apollo01 to If so how can I solve? I have 2 network card because in my mind in the future I have to enabled the link aggregation for better performance
  2. I had a fresh install yesterday and I have the 3.9.1-0 version of Rockstor
  3. I don’t modify in any way directly the smb.conf file (but if it is necessary I’m here and I can do)

Hi @pinguinone, and welcome!

I’m a bit short on time, so please forgive my brievety.

I agree with @phillxnet: it’s most likely DNS… (it most often is). Can you ping apollo01 as well as its IP from your Win10 machine?

With regards to interfaces, by default Samba listens on all interfaces unless specified otherwise:

interfaces (G)

This option allows you to override the default network interfaces list that Samba will use for browsing, name registration and other NetBIOS over TCP/IP (NBT) traffic. By default Samba will query the kernel for the list of all active interfaces and use any interfaces except that are broadcast capable.

Hope this helps.


Hello @Flox thanks for your answer and absolutely no problem for the brievety. I think also that is a problem of DNS but everything seems to be ok for me. I recorderd this video because an image (or better with a video a lot of images) is better than few words:

Here you can see exactly the problem, the pings and the settings. I really don’t figure out where is the problem and how to solve it



1 Like

Thanks a lot for all the additional details.

I’m curious about one little thing that is worth ruling out before digging deeper: whether or not we simply need the share name here when using the hostname.
Would you be able to verify if you can access a share by entering the path to it in Windows Explorer?
\\apollo01\Photo, for instance (I believe this should be one of your samba shares based on your video).

1 Like

Hello @Flox and thanks for the answer. Yes \apollo01\Photo (and also \apollo01\Scanner) is a shares. I try with windows 10 to access to \apollo01\Photo but the result is exactly the same as the error that you can see in the video when I try to access to \apollo01\


I ran into some similar issues, especially after Windows 10 moved into the Creator’s update and beyond and disabled the SMB1 and the whole NetBIOS thing. Even declaring Rockstor the Master Browser didn’t solve it.
My current SMB settings are like this:

so I have a workgroup and a netbios name defined …

In addition, I ended up installing a wsdd daemon (windows discovery service) since I still couldn’t see the SMB shares in my Windows Explorer …
Unfortunately, this was 2 years+ ago, so I don’t exactly know what I did, but I believe, I used this one:

GitHub - christgau/wsdd: A Web Service Discovery host daemon.

I don’t remember giving it extra options during the start, so it attached to all network interfaces, but since then I have been able to access my shares from Windows machines just typing the NetBIOS name into the search bar … since my “prod” server is still on CentOS I could install the package directly…

That solved the issue for me finally. Not sure, whether this will work for you or not … and since this was all based on various searches, there might be a much simpler approach to solve this … I’ll see what happens when moving to the Rockstor 4 version, as I have not tested it in that regard.


Hello @Hooverdan
thanks for your answer now it function pretty well !!! Now for the community and future research of this topic:
Short story:
“it could wooooork!” :slight_smile:
Long story
As you write to me it needs to be update Rockstor so I did this step:

  • Configure Samba = Go to System > Services and Configure Samba with this data:

    netbios name = Apollo01
    os level = 255
    local master = yes
    wins support = Yes
    preferred master = yes
    domain master = yes

  • Install wsdd and previuos program to run it = connect with SSH (by root) and I run this command:

    yum install epel-release
    yum install dnf
    dnf install wsdd

  • Restart Rockstor

  • Wait about 10 minutes

  • Try and smile :slight_smile:

Thanks to all the community for all the support for this matter especially to all the person answered me



@pinguinone, glad to hear it worked! I think you could have also installed it directly with yum, without having to to use dnf. I think I did it using yum, as I couldn’t find dnf installed on my box. I guess, I should document better when I do things like that :). Regardless, glad it works.