SMB Shares trouble

Hey all.

I have SMB shares installed on Rockstor for about 2 weeks, everything has worked fine.
I noticed today that I couldn’t access my SMB share via android (using ex EX and CX FM) but yet they were working in Windows.
I have 2 nics installed in my window box, one a 1gb nic and another 10Gb mellanox and both connected fine, but with android it failed to connect.
After some troubleshooting I noticed that if I restart networking on the Rockstor I can then access via android. This is reproducible on every Rockstor boot so far and is really annoying.

I remember I had problems in FreeNAS where I had to set the SMB min protocol in smb.conf, but I tried it in Rockstor to no avail.

Any help would be appreciated. I was using FreeNAS for almost 10 years but I wanted to try something new.

I have found that since the changes to SMB protocol, Android apps were a little harder to configure.

I have both SolidExplorer and AndSMB working as follows:


Host: (hostname works instead of IP, but is slower to start)
Path: video


Share: video