[SOLVED] Blinking cursor after GRUB

Hi, here I am again with my bi-weekly issues :frowning: This time I did install mlocate and while trying to get the DB updated, the system got unavailable several times (systemctl restart rockstor didn’t help, so a reboot was required every time). After the last reboot, the system doesn’t come up at all.
I can see grub showing the 4.6.0-1 kernel, when selecting that one, I see a blinking cursor in a low screen resolution, then it switches to a higher resolution and that’s it. No output, nothing.

I’m running Rockstor 3.8-14. Here are some pictures of my screen and configs.

I guess the most simple thing to do, would be to reinstall, but I’ve already noticed that the system finds the disks, but can’t use them. I need to wipe them before they can be used, so that is also not an option.

@phillxnet : your suggestion in another post to set the kernel parameter nomodeset also did not help.

Thanks for helping me out,


Ok solved, the / directory was full and did prevent booting.

1 Like

@greggy Thanks for the update. I have a sporadic booter here as one of my test machines. Have narrowed the hardware culprit down to the msata devices as moved everything else bit by bit from one machine over to a completely separate machine and the fault travelled with the msata device, not the adapter even as I switched that out too for an identical model but the msata stick itself: a TS32GMSA370 model. So that was another frustrating find. Putting here as meant to respond earlier with this info but have been otherwise engaged. Had very similar behaviour to yours as well, ie flashing cursor in top left. When it does boot there is plenty of root space so guess it’s unrelated.

Thanks again for reporting your findings, bound to help others.

1 Like