[Solved] Bonding Issues 4.0.9 cant reach NAS

Hi there,

i am a new Rockstor User and am trying to get my setup online.
Anyway, its my first time using Suse and Bonding.

I have installed Rockstor 4.0.9 successfully on my Terramaster F2-221.
Before setting up my first Rockons i would like to setup my HDD and Network Bonding.
My NAS is attached to an Ubiquiti USW-Lite-8-POE, I’ve already had the Port aggregation configured because i had used the Port Aggregation in the Terramaster OS and it worked.

After the initial Setup eth0 was configured via DHCP to use 192.168.11.197
I choose to setup via Rockstor UI the Network Bonding as follows:

    Bonding devices eth0 & eth1
    IP 192.168.11.100
    Gateway 192.168.11.1
    DNS 192.168.1.96

After saving and rebooting i was not able to reach my NAS. I was able to figure out, there was some mistake in the configuration and it was reachable on 192.168.11.8 leading to an configuration like:

Bonding devices eth0 & eth1
IP 192.168.11.8/24
Gateway 192.168.11.1
DNS 192.168.1.96

So, okay, it wants the Netmask, no problem. Changed the config to:

Bonding devices eth0 & eth1
IP 192.168.11.100/24
Gateway 192.168.11.1
DNS 192.168.1.96

Again, reboot.
But now, i am not able to reach my NAS anymore. In the Ubiquiti GUI i can see it with the IP 192.168.11.100.
I am able to login local on my NAS (praised be). So i am able to investigate further.
I am able to pin 9.9.9.9 and 8.8.8.8, but neither i can SSH on to my NAS or using a http(s) connection.

I would be glad if anyone could help me resolving this issue.
Either by deleting the bond and using only a single port or by getting it right.

Best regards

@Sakujakira Welcome aboard! I’m sorry I am unable to help with the network bonding issue. However, installing v4 on a Terramaster NAS sounds interesting - a very cute form-factor running Rockstor is very appealing. I assume there is some form of embedded storage to hold the OS, with the drive bays purely for data?

Thank you! Yes, there is an small Thumbnail Sized USB Stick Onboard which can be switched (i am using SanDisk UltraFit with 128GB) and used to install the OS.

1 Like

@Sakujakira Hello there.
Re:

Nice.

Always handy :slight_smile: .

One pointer that my help is that we use network manager ‘under the hood’ so you could try using for example nmcli to investigate and configure as you require. Tricky to know the issue re Web-UI config/mis-config/bug wise but nmcli should help to know the current state and allow you to reconfigure as required.

Hope that helps.

3 Likes

Thank you @phillxnet , your hint led me right.

Oddly, i am sure, i configured in the second attempt 192.168.11.100/24, but ip address said 192.168.11.100/32 (Maybe because the first save were nonsense)

I decided to make it easy, i removed the bond with nmcli, after a reboot it came back with the defaults and the Webinterface was reachable.
Now i´ve configured a new bond and it worked.

3 Likes