[SOLVED] First boot not working with redundant install of Rockstor v3.8-13

Hi guys,
I followed the procedure posted here http://rockstor.com/docs/mdraid-mirror/boot_drive_howto.html and I’ve encountered the following scenarios:

  1. Installed as ext4, rebooted into recovery, waited for disks to sync up with mdadm then upgraded the root partition to BTRFS and when I’ve tried to install again then the BTRFS partition was not letting me to add another one saying that there is no disk space available. Started everything from scratch and this time I didn’t waited for the disks to sync up, upgraded to BTRFS and this time worked.
  2. Starting the OS I have the following error and the system get stuck:
    Reinstalling again the os sometimes if entering into some kind of debug/recovery mode.
    I’m trying to install the OS on two Kingston 128 GB SSD’s. I can install CentOS 7.2 on the same machine without any issues.

Did anyone experienced the same thing with redundant install?


Well, I have identified the issue, I was modifying the BTRFS as redundant not single as it was not clear that the redundancy will be handled by mdadm :slight_smile: now everything works fine!

1 Like

@shocker Welcome to the Rockstor community and thanks for reporting you findings on this one. Yes the system on mdraid was purely to address redundancy and as you say, as far as btrfs is concerned this is a single device install. That way we circumvent the current issues with booting btrfs directly. Bit of a palaver to install this way but it does seem to work in the end.

Linking to @Spectre694 's thread “Install to full disk BTRFS” which has an informative discussion in the area of booting to btrfs.

1 Like

Seems that there are still an issue. I previously managed to login, buy the activation key for 5 years and performed the stable update + yum update in cli and installed wget without no extra modifications. After restarted the system I have this error:

and it’s getting stuck like that. Tried to reboot few times and the result is the same.

Any ideas?

@shocker That’s a shame and a nuisance. I’m afraid I have to dash now but just wanted to link to:
Are stable updates key/licenses transferable?
Reinstall activation
to alleviate any worry on that front.

Oh and just to add that I do have a system here based on the howto that has survived all updates to date from the time that howto was posted so I’m a little at a loss currently. I also have an install using a generic intel bios raid install (which also involves mdraid) for the system disk (in mirror) that has also survived all updates. Just throwing in for context.
Sorry but I have to dash now.

Does this bring anything to mind for anyone else?

Thanks for the feedback. Currently reinstalling and see if I can reproduce the issue :slight_smile:

I’m on the final stage

Reinstalled and the issue is the same the OS is not booting:

Digging I can see that there are errors with the cxgb4 and this is the driver for my network card, Chelsio T580-CR. Not 100% that this is causing the issue but is anyone here is using Chelsio network cards?

Managed to install kernel 3.10.0-327.el7.x86_64 and everything is OK now. Just read the driver specifications on Chelsio and the maximum supported kernel is 4.1, and indeed that was the issue caused the hanging. I’m going to use another adapter tomorrow with 10G. Maybe this solution will help someone else to not loose nights reinstalling over and over the os :slight_smile:


Installed the new os with the dual 10G SFP+ adapter from Supermicro and everything is ok now. Indeed the issue was caused by Chelsio T580-CR driver already present on kernel and that was the case for the failure.

It’s a shame that the latest drivers from Chelsio released on Apr 27 2016 don’t support new kernels…

@phillxnet thank you for sharing the re-activation procedure. Just sent the email to get the new code.