(Solved)Importing/Loading files from USB (FAT Structured)

To provide a view on the windows connection. I am using wsdd to support the WS-Discovery, since SMBv1 has been disabled in Windows 10/11 for some time now. That way Rockstor is recognized on my network by windows machines without an issue. I have submitted a Rockon for that (still in review) on GitHub, focused on Workgroup based networks:
https://github.com/rockstor/rockon-registry/pull/294,

But, of course, you can also directly install it on your Rockstor instance. See here for some information I put into a feature request but it does require to add another repository:

https://github.com/rockstor/rockstor-core/issues/2322.

The way I’ve set up my Samba service is based on a lot of past fiddling, so some of the settings might not be necessary anymore (like the os level, domain master, etc.), but I didn’t want to mess with a working system :slight_smile: :

image

The key inputs for the wsdd service are the HOST_NAME (name of your rockstor appliance) and the WORKGROUP (if you use Active Directory, there is another parameter) the appliance belongs to in the windows network. Once that’s taken care of, I can easily access all Samba “exports” I have created (in this screenshot I set up shares for all of the config directories of Rockons so I can take a look at them when necessary:
image

1 Like

@Hooverdan Nice; but are we not over-complicating this for an initial connection.

Does our current doc section here:
https://rockstor.com/docs/interface/storage/file_sharing/samba_ops.html#how-to-access-a-share
no longer allow for initiating a list of available shares accessible by say the samba admin user. Sorry I’m a little out of touch on the windows side.

Cheers.

Just looking for improvement for getting folks off the ground as simply as possible. And we need to take a fresh look at that Rock-on you posted. Apologies for not getting around to that one. But it should surely be a nice to have not a critical component. Am I missing something here on the new fangled windows side. Is it really now this difficult to find and connect to a NAS running a modern SAMBA, as they mostly all do. We do have what I believe to be a working avahi setup currently. Maybe we need to tweak that some?

Thanks for any schooling in advance.

@phillxnet, yeah, yeah, you’re of course right :slight_smile: I read too much into the “connecting” piece of server name vs. ip address.
As for the documentation, I realize that for the windows portion, one backslash is missing.

image

so it should be \\192.168.1.21 instead.

My understanding is that Windows does not recognize the avahi based registration (yet/still/never, I don’t know), hence the need for wsdd - if you want to address Rockstor not by its ip address, but its appliance/server name. that’s how that seemed to work out for me, I could only see the server name, once i installed wsdd … but like you, I’m ready to be schooled in this area :slight_smile:

1 Like

@Hooverdan Thanks.
And:

Nice. Fancy creating a doc issue for that one :slight_smile:.

This is all good. Weeding out a few paper cuts along the way.

It is looking like we should probably look to getting that rock-on in as a quick start for folks that are less familiar with using direct ip addresses and the like. But we should also have less buggy docs on an out-of-the-box client connection.

Cheers.

1 Like

@phillxnet, Done:

Feel free to augment/change as you see fit.

1 Like

Thanks to All for adding their bit :slight_smile:
It seems that windows users are in the minority at the moment, so how long will it be for a Rockon to be available in the Rockon downloads as I don’t think my tired brain could handle all those switches and variations listed (for goodness knows what reasons) in the GitHub - christgau/wsdd: A Web Service Discovery host daemon.
If the lead time is months away I might try the FreeNAS version as it seems it has wsdd already included in the distro, but could wait a few days whilst the box heat soaks (doing-- not a lot) and I can get in the garden or even fix up the festive lights.
The introduction of a second \ to the File Explorer address still hasn’t revealed the goods.
If Microsoft has removed recognition of the avahi based registration, what would be the point of pursuing ways to improve use of it, why not just add the workaround (wsdd) to the installation remove all the old stuff from the docs (its no longer relevant) and move on. Wouldn’t this improve the situation for windows users and possibly increase the patronage.
But then hey what would I know, I’ve only been here 5 nanoseconds :face_with_monocle:
Thanks again

1 Like

Am I missing something here? All I have ever done to connect to my Rockstor instance is to map a drive in Windows File Explorer, using the IP address of the NAS, together with the share name. This has always worked as I need, but I’m not a heavy windows user.

Agreed, the windows share discovery in the explorer would be nice, but for a simple fully functional connection to my shares this works fine for me. Network share discovery works fine with my Linux devices.

Each share needs to be mapped individually. However this will work to enable the population of the empty shares with data from the backup (assuming it is a USB drive plugged in to the Windows machine).

3 Likes

@Mike-B Re:

I know this might be a silly question, but did you try this with your Rockstor’s IP address. I.e. via the:

myip

program executed on the rockstor machine. See the following installer how-to sub-section:

https://rockstor.com/docs/installation/installer-howto.html#login-as-the-root-user

Because as @GeoffA indicates and also from the wsdd upstream GtiHub repo we have:

… using Samba as file sharing service is still possible even if the host running Samba is not listed in the Network Neighborhood. You can still connect using the host name (given that name resolution works) or IP address. So you can have network drives and use shared folders as well.

However for the nice-to-have network appearance via wsdd regarding @Hooverdan’s Rock-on submission,

I’m testing the Rock-on as we speak. And will post progress here shortly hopefully.

Hope that helps and again apologies if I’m pitching way too low here. It’s always difficult to know folks knowledge and not everyone has a base handle on ip stuff, even when setting up a DIY nas. Plus a particular aim in Rockstor, shared by all the main contributors currently, is to have it be an easy on-boarding process. You are currently subject, hopefully willing, to that aim. Hence me having a quick look at @Hooverdan’s Rock-on. It may well be as you say a blocker for many. Plus @Flox is considering again our client docs on an issue that I unfortunately closed by accident and our major work on getting the v4 Stable ready go lost in all the other things going on code and doc wise.

Again you involvement and pointed questions are helping us to prioritise.

Avahi is used by many other systems, pretty much all other systems actually. I.e. TV all other OS’s etc. Microsoft has their own ways of doing things and has a long history of being antogonistic to all but their won systems. We play against this ‘flow’. But times are a-changing.

We don’t only serve microsoft clients OS’s and linux is pretty good at using standards that are across the board, unlike many elements in the history of Windows. And we like to stick to standards.

The wsdd is a hack of sorts, hence the Rock-on approach. It may be we end up implementing it as say a service, we will have to see.

I hope so. Again we aim to be an easy to use and configure NAS. But we are still in the DIY realm where folks strongly expect an ability to customise or go their won way completely.

I’ve only been around for a fraction of the projects like myself. About half of it so far I think.

I’ll get back to looking at that Rock-on as you may be an ideal candidate for it’s field testing.

Given Windows is on around 90% + of client systems, I doubt that. But we collect no metrics so simply can’t say. But we definitely have a mix of Windows, OSX (mac), linux (pretty much all variants I suspect). And all over many years now.

Hope that helps.

3 Likes

Hi @Mike-B,

As @phillxnet mentioned, we’re currently working on updating that very part of the documentation as it is indeed a very important one.

To clarify things, everybody above is correct, it’s just that Windows has a few ways to achieve this and its own peculiarities at the same time. You can setup a Samba export and access it from your Windows machine in a very simple way without having to install any Rock-on, though. Very briefly:

  1. Set up a share on Rockstor that would be then exported (if you haven’t already created it). The only thing to which you need to pay attention, though, is access control. You indeed need to ensure you have a Rockstor user that has access to this share. For instance, in my test case, I created a share called test_share01, and set up the access control of this share to “owner”: my rockstor user, “group”: users.

  2. Configure your Samba service. Go to “System” > “Services”, and click on the little wrench icon next to the Samba service. For the Workgroup field, make sure to put in the same workgroup as your Windows machine. The default in Windows is WORKGROUP, so unless you changed it, you can simply enter WORKGROUP in this field; the rest is only optional. See screenshot below:
    image

  3. Turn ON the Samba service.

  4. Set up a Samba export for this share. Make sure to set up that Rockstor user used above as “admin user”. See screenshot below, for instance:
    image

  5. In your Windows machine, you can then access your samba export. This is where things can be done in a variety of ways. The easiest in my opinion is the following: enter the path to the samba export in Windows Explorer address bar. The convention here is:

\\<rockstor-machine-ip>\<name-of-share>

So in my example, for instance, it would be as follows:
image

Once you press enter, you should see a Windows dialog window pop up, asking for login and password: simply enter the login and password you set for the Rockstor user that was set as “admin_user” and owner of the share. In my example, the login was radmin and the password was the password for that user.

That should be it.

Note that the wsdd service and Rock-on that @Hooverdan worked on will make it so that your Rockstor machine and samba exports will be visible in the “Network” section of Windows Explorer without you having to manually enter the path of the samba export, but it won’t affect your ability to access these shares, only their initial visibility/discovery by Windows.

Let us know how this goes and then we can adjust things as/if needed.

3 Likes

Thanks Flox
I have rechecked the share settings as suggested for WORKGROUP and User.
All are correct
Group is: “users”, Admin Users is: “Mike” The Share is: “Photos”
This is the result.
Win11%20Network%20Address
I would be more than happy to test anything that can help.
As far as level of understanding low is good.

Delete the ‘Network’ bit in the address, it should be just

\\192.168.0.22\Photos

That should work, and will bring up the login credentials dialog for the share.

3 Likes

Thanks phillxnet
Re the “myip” section, not having used the system shell before, I have just tried and can’t seem to get past the password stage, tried all possibilities to no avail. Hope it isn’t important, if so, I can always reinstall the system and record any that crop up during the process.
I got the ip from the initial install text whilst still on the monitor.
Nice to hear your testing a potential rockon and would like to be involved however it might be more painful for yourselves than me considering my level of understanding all things in the Linux arena.
Point taken re the “avahi” topic.
Just seen your reply GeoffA, went to try it and hey presto before I had chance the Rockstore hostname popped up with the two shares.
Unfortunately the image wont upload.

I hope its still there in the morning :slight_smile:

2 Likes

Thanks Flox
Shut it down and restarted, yep can still be seen, the next problem is to get around this:

File%20Explorer%20result%202
You mentioned
Once you press enter, you should see a Windows dialog window pop up, asking for login and password: simply enter the login and password you set for the Rockstor user that was set as “admin_user” and owner of the share. In my example, the login was “ radmin” `` and the password was the password for that user.

I didn’t get that but permission is required and Windows seems to be not allowing me to make changes in permissions for the Network.
Unsure about the next step, the Rockstor Hostname is MjB but Logging in is completed in the name of the user (Mike) and a password, I hadn’t realised that somewhere along the journey I have used two sets of credentials, one for the Hostname another for the user.
If there is no way out, discovering the password or making changes to get around it, a reinstall could be achieved. (Still got the USB)
At least we have moved on, trouble is I really don’t know why or how it was achieved as I haven’t changed anything.

@Mike-B if I look at one of your earlier screenshots, it looks like the Photos Share is set to read-only:

image

So that could be the issue in this particular case.

2 Likes

Thanks Hooverdan
It has since been corrected, possibly in response to the notes by Flox.
Gladly windows is still recognising the shares, oddly enough it seems to respond better when using the hostname instead of the ip address. Weird or Interesting?
Just need to get over the permissions issue. :frowning: to get started with some share population. Then move onto Plex possibly and/or other Rockons.

In answer to question I replied to from the good @Flox
Unsure about the next step, the Rockstor Hostname is MjB but Logging in is completed in the name of the user (Mike) and a password, I hadn’t realised that somewhere along the journey I have used two sets of credentials, one for the Hostname another for the user.
If there is no way out, discovering the password or making changes to get around it, a reinstall could be achieved. (Still got the USB)

Have just logged onto the System Shell as a user, (suddenly realised I didn’t need the Hostname and password) The “myip” command returns

**Mike@MjB:~> myip **
-bash: myip: command not found

Possibly it is no longer required as the shares can be seen in Win11 File explorer (In fact I now get a little drop down list to select which share I wish to access) although I still have to obtain permissions to do so. Win11 is not allowing permissions to be changed for the folder/Files I wish to copy to the share.

Any ideas as to how to achieve permissions when not allowed would be greatly appreciated.
AND
Thanks to all for their support, it has been an interesting journey

When you are logged in as Mike, the command ip a will give the IP address, look for soemthing like eth0 as the interface name, and the line commencing inet

Just to clarify, the command is:

ip a

Hi @Mike-B,

Thanks for your kind words and a sustained friendly and constructive discussion, it is benefiting everybody!

Something in your latest post caught my eyes (reformatted for clarity):

I’m a bit perplexed by the fact that you seem to be logged in to your Rockstor machine using your Mike user, and that the myip command cannot be found. What is catching my attention is that–if my memory is correct–the only user allowed to connect to a Rockstor machine by ssh is the root user. I thus wonder how you can get a prompt Mike@MjB.

As you seem to be able to view your samba export from your Windows machine, I believe you are now sure of the IP address of your Rockstor machine. In this case, from windows, could you try the following?

  1. open the Terminal app (hopefully it is called the same in Windows 11 than in Windows 10).
  2. type the following command to connect to your Rockstor machine using its IP address; for instance, my test Rockstor machine has the IP address 192.168.122.92 so I would type:
ssh root@192.168.122.92

From your earlier screenshot, yours seems to be:

ssh root@192.168.0.22
  1. then the myip command should work.

Going back to your Samba permission issue, could you post a screenshot of your “Access controls” tab for the “Photos” share? In the example I detailed in my previous post, mine is as follows:
image

Let’s take it from there and see what we have for now.

1 Like

@Flox I took it from @Mike-B that he was using shell in a box in the GUI rather than SSH. My GUI shell does not allow root login: I use my admin account, and myip is not available to that user.

However, I usually use SSH from my laptop with root user, and myip is available there.

Not sure if that helps?

2 Likes

Here it is @GeoffA
Shell%20output%20(Re%20ip%20a)

Its probably better that you review the output as it means little to me.
Thanks