[SOLVED][January 6th] Failed to connect to updates.rockstor.com:8999/rockstor-stable. Is the Rockstor system connected to the internet

Yet another inability to register post:

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py”, line 41, in _handle_exception
File “/opt/rockstor/src/rockstor/storageadmin/views/update_subscription.py”, line 86, in post
stableo = self._toggle_repos(password=password)
File “/opt/rockstor/src/rockstor/storageadmin/views/update_subscription.py”, line 58, in _toggle_repos
status, text = repo_status(ono)
File “/opt/rockstor/src/rockstor/system/pkg_mgmt.py”, line 154, in repo_status
raise Exception(e_msg)
Exception: Failed to connect to updates.rockstor.com:8999/rockstor-stable. Is the Rockstor system connected to the internet?. Lower level exception: HTTPConnectionPool(host=‘updates.rockstor.com’, port=8999): Max retries exceeded with url: /rockstor-stable (Caused by <class ‘socket.error’>: [Errno 111] Connection refused)

Literally just tried this before I typed this post

UPDATE: I’ve since received my activation code via email, took a few hours, per the correspondence on this thread.

This I am sure happened during a brief downtime while I updated our forum software(Discourse). If it happens persistently, then please check your internet connection.

It also occurs to me that I was entering the wrong code in the registration page - after clicking the link in my order email, it says that my order is confirmed, and that “we’re getting it ready”.

It’s been like this for about half a day - what’s the normal processing time to receive a license code?

Oh My Fracking Buddha

I tried to post the errors from yum update and got a message from the forms that new users can only post two links.


I’ll save the coming rant for another post. About to give up on Rockstor for personal use and at this point can no longer consider it for business use.

"Failed connect to updates.rockstor.com:8999; Connection refused"
Trying other mirror.

@adworacz Hello again and thanks for you patience.

It does now look like we have an issue with the stable registration / updates system and project lead @suman is aware and will sort as time / complexity permits.

Yes that’s no good. Normally you would receive an email with the activation code within 10 mins. Apologies for the inconvenience.

@Carl_Banks Welcome to the Rockstor community, rather a rough start for you from the sounds of it. Please understand that this is also frustrating for the admins and developers and I think everyone also appreciates a degree of civility as ‘stuff’ does have a tendency to happens.

We use discourse which is generally well regarded and as far as I’m aware we default to their defaults re initial user restrictions. Even so we have had some issues with spam / trolls but we also try and moderate and it is a shared hope of the Rockstor team that we try and keep the forum as pleasant and free from noise as possible. Some automation in this regard is inevitably going to have false positives.

Hope that helps.

Thank you @phillxnet! and welcome @Carl_Banks. There was an oversight on my part that caused this. The subscription service was up for a while but went down unexpectedly sometime after the maintenance window. I solved it since and so far it’s looking good. we’ll keep a closer watch on it for the rest of the day just in case.

Quite creative and really funny!

1 Like

I’ve been using forums for over 15 years and it seems like discourse is trying to reinvent the wheel.

It seems like it was designed to be optimized for mobile and hides lots of common features in the upper right icons.

I wasn’t really able to sign-in with google, it used google to create an account. On other sites with two clicks I’m signed-up, logged in, and ready to post.

And having a minimum title length of 15 seems rather arbitrary. I want to post about using Rockstor, not be told how to communicate by discourse.

When I’m trying to fix my file server at 2 am local time (normally asleep by 11:30 pm) the last thing I want is to try and use a forum to report an issue and the forum won’t let me.

I’ve received my code. I’m running a full reinstall (enabling encryption from the ground up). Will use my code to ensure I get the proper updates.

Welp, after a fresh install, my activation code doesn’t work:

        Traceback (most recent call last):

File “/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py”, line 41, in _handle_exception
File “/opt/rockstor/src/rockstor/storageadmin/views/update_subscription.py”, line 86, in post
stableo = self._toggle_repos(password=password)
File “/opt/rockstor/src/rockstor/storageadmin/views/update_subscription.py”, line 66, in _toggle_repos
raise Exception(e_msg)
Exception: Activation code() could not be authorized. Verify the code and try again. If the problem persists, contact support@rockstor.com

I assume it’s because my UUID changed?

@adworacz Hello again and thanks for helping to support Rockstor.

Sorry for my slow response.

Yes, very irritating.

Correct. Rockstor does try to use a bios hosted uuid that doesn’t change from one install to another using the same motherboard but some motherboards are made ‘lazy’ and have all the same uuid, which is obviously a problem if depended upon to be unique. So if one of these ‘fake’ uuid’s is found we have no choice but to rely on one that is install, rather than motherboard, specific. To confirm this as the issue try the following command:

cat /sys/class/dmi/id/product_uuid

if the result is one of the following:




Then you have one of the known unreliable (as in on every motherboard of it’s type) as in Non unique motherboard uuid: which is ironic given what uuid stands for.

I have 2 of these motherboards myself:
ASRock N3700-ITX
ASRock C2550D4I
both of which have a product_uuid of “03000200-0400-0500-0006-000700080009”. Nice!!

The official ‘work around’ for this is to email support@rockstor.com with your old and new Appliance ID: your existing activation code can then be transferred over to the new appliance id.

Hope that helps.

Ah yup, here we go:

[root@beastoriousnas ~]# cat /sys/class/dmi/id/product_uuid

Here’s my Mobo (ASRock J3455 ITX) : https://www.newegg.com/Product/Product.aspx?Item=N82E16813157728

I already emailed support@rockstor.com, but I didn’t provide the old UUID.

I’ll resend my email with both my old and new UUID and the Activation code in question.

Edit: Email sent.

Everything has been fixed!

After sending my email to support@rockstor.com, with old and new UUID, my activation code was transfered and I was able to register my new NAS, updating appropriately.

Thank you!

@adworacz Thanks for the update and glad your sorted.

Bit of a nuisance that fake motherboard uuid.