[SOLVED] Many TB of data hang in the balance. Can you help me resolve this Rockstor error?

A drive began to accumulate SMART errors yesterday, prompting me to attempt to remove it from the pool. The removal failed because without it, there wouldn’t be enough room to store the remaining data on the pool in RAID1. I began the process of converting the pool to RAID5 using the web GUI. It began successfully. However, when I logged in the following day to verify the conversion completed successfully, there was an error on the dashboard. The same error also appears on the Shares page.

When I attempt to access the pool, there’s another error, which look like this:

Since these errors have popped up, I’ve been unable to access my shares, although the dashboard still reports the correct free and used space. The pool is listed as RAID5 in the GUI, which appears to indicate a successful conversion.

What is my next move to get these shares back online? I’m running 3.8.16-16 and I’m happy to provide whatever logs are necessary.


UPDATE: Searching around led me to this post, which makes me think this error has nothing to do with my disk resize and something to do with a recent upgrade from 3.8.15 to 3.8.16. I’ll try troubleshooting using information in that thread.

UPDATE2: Rolling back to Rockstor 3.8.16-12 resolved the error. Seems to be something wrong with the most current testing builds.

So out of curiosity: all shares and files are there right ?

If yes I will STRONGLY advice to acquire another disck, add it to the pool and go back to raid1, because (and even thou it looks like shouting) RAID 5 & 6 UNDER BTRFS IS VERY NOT ADVISED FOR PRODUCTION !