[Solved] NFS export empty/not mounting after reboot

I was able to reproduce the issue on a VM

  1. Make a Raid 10 Pool
  2. Make a share
  3. Make an NFS and a Samba export.
  4. Create a new user with the UID of 501, delete the old admin user. Change the owner rights of the share files to the new user with chown. Connect to the NFS share and add some files.
  5. Reboot
  6. Connect to the NFS share

Files to be visible

What happens:
Files are not visible. When SSH’ing to the box the share isn’t even mounted properly.

Server: ROCKSTOR 3.9.1-0 through ROCKSTOR 3.9.1-16

@Ray_Foss Hello again and a belated welcome to the Rockstor community.

Thanks for the nice clean report. But could you first try selecting at least one of the update channels and applying all the fixes their in as 3.9.1-0 (un updated latest iso) is now pretty old. Hopefully their should be a fix or 2 in there that addresses this issue and if not then we can take it from there.

Also it would help to confirm the installed Rockstor version after update via:

yum info rockstor

We did have some major changes around that time that may have affected this and are hopefully now fixed in both channels. See how that goes and also paste any relevant rockstor.log entries that look to indicate a mount or nfs failure.

Hope that helps and let us know how that goes.

That was my next step… I tried it in the latest testing ROCKSTOR 3.9.1-16 with a new Single drive pool, exact same issue, I can connect to the NFS share, but it appears completely empty.

  • SSH’ing into the VM reveals neither the Share nor the export are mounted
  • Connecting with Samba first will mount the Share and Export, but NFS will still be empty

It’s as if nfs was binding to the pre-mount folder

Hi @Ray_Foss,

Can you provide the output of the following command:

sudo cat /etc/exports


Before a reboot and after, I get the same result

/export/TestShare *(rw,async,insecure)

I updated and created everything from scratch. Now things do mount automatically, but the NFS service is inaccessible remotely, unless I manually toggle it on and off. All the ports show up in netstat and I can connect to them with netcat from the client. It’s as if NFS server softlocked. After yet another reboot, everything worked normally.

I’ll post an update if I find anything while fixing the issue on the production server. It seems to be a problem with upgrading pools/shares/users from 3.9.1-0