[SOLVED] Problems with Apollo Lake Celeron J3455


I’m new to Rockstor and currently trying to get it booting on a relatively new Intel Celeron J3455. As the current CentOS plattform seems to have issues with these processors I wanted to ask wether there are some testing builds/isos I can try to get it to boot.

Thx in advance.

Hi Flo,

i’ve installed rockstor on an ASRock J3455-ITX NAS. The installation was a little bit of a hassle, mostly because i wasn’t experienced with the UEFI bios, but now it’s running smoothly.


First thing I did was disable that UEFI shit. Did you do anything special? I’ve tried it with the iso from the download page, which didn’t quite boot into the installation process (some wierd error/kernelpanic). I’m running this board: https://geizhals.de/asrock-j3455m-90-mxb450-a0uayz-a1525589.html
Any suggestions?


i think its the same board here, just the itx version.
iirc the important step was to enable ‘CSM’ in the bios.
The next hurdle was, that the default boot menue was too short, rockstor always booted the uefi boot option with the result that not the rockstor boot screen showed up but the CentOS boot screen. iirc the solution was to press ‘f11’ at boot for a larger boot menue where i could choose the non uefi boot option.

HTH, Bert

1 Like

I didn’t read the stuff… just type exit to get out of the emergency console and the setup continues. Other from it being really really slow (which is kinda expected, cause hardware is unspported by old kernel) it works now.

Thx for your help.
Hoever I have a new problem now :smiley:Cannot access smb share

The problem is the release of Centos7 on which this Rockstor release is built. I did some tests using my Asrock N3700 ITX with both the latest (201612) and the previous release. The latest was fine with UEFI but not the previous. In fact upgrading from Rockstor -14 (I think) to -16 borked my system. Im hanging on now until Rockstor migrates which as I understand it is not trivial.

This post was very helpful. I started installing Rockstor on a ASRock J3455 ITX board and was running into the same problems. Specifically the launching of the Centos boot menu instead of the Rockstor boot menu, and the dracut-initqueue timeout issue.

I did enable CSM in BIOS, and I did have to select my boot options via F11 so that I could boot from non UEFI mode (just selected the option that starts with “USB”).

I was able to get the graphical installer to come up (everything is just REALLY slow…) and now I’m running an install to see how things go.

Edit: This is with the latest downloadable ISO version from the web page: 3.9.1

Install completed successfully. Had some wonky display issues via my TV, but they eventally cleared up on their own, and I’m able to access the Web UI.

@adworacz Welcome to the Rockstor community and thanks for sharing your findings. Hopefully things will go more smoothly when we next rebase our iso on a newer CentOS release as per:


2 years later I have exactly the same problem…
so seems nothing has been solved.
from the messages above, I can understand that it is necessary to enter in the BIOS and to enable ‘CSM’ in the bios. (even if I don’t understand what you are talking about, LOL!)
then this action should allow me to select another boot option, which can work to install Rockstor…
got it right? thanks for your feedback.
I installed already one system based on a J1900, it is working very good, but I invested in a more “powerfull” system with the J3455, so I was very upset when I saw it was not working at all, trying to modify my USB boot disk…
so now I understand I am not alone facing that problem
best regards

@Aragorne-64 Welcome to the Rockstor community.

Yes, our installer is the exact same one. But we are very shortly to release a new installer by way of a re-launch of sorts. We have spend the interim time transitioning Rockstor to be based on openSUSE instead of CentOS. So upon that installer being released I would be very interested to see if you have a better time of things. I suspect you will :slight_smile: .

The following thread has the most up-to-date info on our openSUSE endeavour and we have just reached beta stage for those testing channel (‘Built on openSUSE’ only) rpms:

But as stated there is no Rockstor specific installer just yet. Still in closed beta trials.

1 Like

Hello, thanks for your kind answer.

following the tips, I have been able finally to install it.

now I have to try it, because I am not sure the things I touched in the bios are all correct…

as a beginner in Linux, I have some difficulties to understand everything :wink:

but at least Rockstor is working perfectly and I created already a “working” structure based on a MB with J1900.

By the way, do you think the usage of a MB with J3455 will give better results?

The CPU looks better on the paper.

The RAM can be up to 16Go, and maybe the usage of one SSD to support OS can help making some cache… but this is I only guess because I don’t know exactly if the system is able to do so…