[SOLVED] Rockon "Uninstalling" all the time


I tried to uninstall Deluge, and now on the page it is all the time grayed and “Uninstalling” with the wrench icon. I cannot install it again nor fully remove.
Is there any troubleshooting to do with it? I’ve already rebooted twice the server


Hello @sebasb, and welcome!

I unfortunately have had that happened to me once with a container getting stuck in a transition state. As you wanted to uninstall this Rock-on anyway, the best solution in this case is to simply use a script that we have to do just that. It is described in several other threads on this forum, but its usage is as below:

/opt/rockstor/bin/delete-rockon Deluge

Please note that the Rock-on name is case-sensitive.
This script will uninstall the container (if not done already) and also remove its entries in Rockstor’s database. That should fix your issue.

Hope this helps,

Thank you for your response. coming from OMV I was looking to “rock*” commands to find something like this and couldn’t find your suggestion :slight_smile:
Next time I will try that. I just did a backup/restore from another post while burning the midnight oil and it worked flawlessly, since the docker container was already remove, then went to sleep.

Thanks for your help

Glad you got it sorted out.

This is actually something that was brought up several times so it’ll probably be improved in the near future–by finding a way to implement the functionality of this script (and others) into the webUI. There is a lot of work being done at the moment on other aspects of Rockstor but that will probably be worked on soon after that.