[SOLVED] Samba Shares Missing in GUI (but exist!)

I have a few Samba shares set up that I can access from other machines, but they are not showing in the web GUI.

I’m worried if I try to add some it’ll remove the existing ones. Not sure where to start with this… I may give it a shot.

I’m running the testing build.

Hi @xantonin can your tell us your Rockstor version and when you first had this issue?


I just updated to the latest, but I’ve had the issue for a long time. I just never needed to update my Samba entries.

System is running the latest Rockstor version: 3.8-14.15

Is there a way I can force the UI to re-read the SAMBA shares, or import them?

Rockstor added shares: from Rockstor Web UI stop and start samba service, that will rewrite smb.conf file (reading shares saved over Rockstor db)

unfortunately there’s no way to have manually added samba shares to Rockstor (and you will lose them on the first samba stop/start from Web UI)

I ran
[root@rockstor ~]# systemctl stop smb.service
[root@rockstor ~]# systemctl start smb.service

And also stopped/started the service from the UI but my shares aren’t showing up. These were all added from the UI too, nothing was done manually.

The shares still work from client machines though. There’s a missing link between the UI and the Samba shares…

I tried adding a test share from the UI:

    Traceback (most recent call last):
  File "/opt/rockstor/eggs/gunicorn-0.16.1-py2.7.egg/gunicorn/workers/sync.py", line 34, in run
client, addr = self.socket.accept()
  File "/usr/lib64/python2.7/socket.py", line 202, in accept
sock, addr = self._sock.accept()
error: [Errno 11] Resource temporarily unavailable

Hi @xantonin, let’s procede with some testing:

What happen if you add a new samba share via Rockstor web ui?? is it listed in samba shares on Rockstor samba shares page??

Excellent, I love testing.

I tried adding a new using one of my former share names via the UI, and it seemed to nuke the 3 shares that were working from the clients (but invisible in the UI).

So I went in and added everything back, and they are listed. I restarted SMB and they are still there.

I rebooted and they are fine now too. I’m not sure what happened but we’ll see if they persist this time.

1 Like

Hi @xantonin,
happy to hear all seems ok. Not so happy about nuked 3 shares, but we hadn’t a different way to test/solve: on every samba share add via WEB UI Rockstor cycle samba shares in Rockstor DB and rewrites smb.conf (so manually added shares get nuked!).
Please never modify smb.conf via shell because you’ll lose every change on first smb restart from web ui (full smb.conf rewrite).

With current infos I’m not able to explain why you had this issue, but marking this as solved

1 Like

Thanks for the help. These were all added via the UI.

I had some issues with this system, maybe they became corrupt. Luckily the 3 shares were simple enough to create.