Some shares are not mounted after reboot

tried several things but nothing worked…

As I’am a noob, I maybe will ask dumb quaestions :wink:

Regards Lumpi

@biefi Welcome to the Rockstor community.

This is a little strange. Could you check to see if this is not a false alert by pasting the output of the following command executed via a terminal on the Rockstor machine:

cat /proc/mounts

As that is the command Rockstor uses to see if a subvolulme (share) is mounted or not, ie if it is mounted then it will appear in that commands output.

You could also look, via the ‘less’ command for example, at the following log:


to see if there are any clues on why these particular subvols are not mounting. Is there anything you are aware of that is common to all the shares that are failing to mount?

Unfortunately our built in log viewer is currently missing the ability to show that log. We should mend this short fall soon.

Hope that helps.

1 Like

Thanx for the answer, checked the mounts, but same results, as i posted above.
What i see in the log loops every 2 minutes:

[15/Apr/2018 21:29:35] ERROR [storageadmin.util:44] Exception: Another pool (rockstor_rockstor) has a share with this same name (dropbox_data) as this pool (Daten1). This configuration is not supported. You can delete one of them manually with the following command: “btrfs subvol delete /mnt2/[pool name]/dropbox_data” WARNING this will remove the entire contents of that subvolume.
Traceback (most recent call last):
File “/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/”, line 68, in run_for_one
File “/opt/rockstor/eggs/gunicorn-19.7.1-py2.7.egg/gunicorn/workers/”, line 27, in accept
client, addr = listener.accept()
File “/usr/lib64/python2.7/”, line 202, in accept
sock, addr = self._sock.accept()
error: [Errno 11] Resource temporarily unavailable

Everything started when I installed the rockon “Home Assistant” after trying to add customization to configuration.yaml and restarting Rockons docker…

Thanx Marcus

  • this also appears is log:

[14/Apr/2018 22:47:20] ERROR [system.osi:119] non-zero code(1) returned by command: [’/sbin/btrfs’, ‘qgroup’, ‘show’, ‘/mnt2/Daten1/rock-ons-root/btrfs/subvolumes/a3a9944873d67b7126d8b0aec0685a47d9eb6e8cf4a17d7384c55419714908b5’]. output: [’’] error: [“ERROR: can’t list qgroups: quotas not enabled”, ‘’]


after deleting share “dropbox-data” eveything runs after a reboot…

Thanx for support…