Support for RTL8125B 2.5GB Ethernet?

Does anyone know if Rockstor’s OpenSUSE versions support RTL8125B 2.5GB Ethernet cards ? I gather Linux support for these chipsets is fairly recent, but I’m not sure exactly when it was added to OpenSUSE itself.

you might have to install the kernel backport on Rockstor (see help pages), depending on your version. I believe that card is supported for kernels >= 5.4. so, the backport might not be necessary.

when I run the below on my appliance (version 4.6.1-0 on Leap 15.4) with the kernel backport (currently 6.7.2-lp155.5.g321aeb9-default) installed, it seems to show up as available

modinfo r8169

filename:       /lib/modules/6.7.2-lp155.5.g321aeb9-default/kernel/drivers/net/ethernet/realtek/r8169.ko.zst
firmware:       rtl_nic/rtl8125b-2.fw
firmware:       rtl_nic/rtl8125a-3.fw
firmware:       rtl_nic/rtl8107e-2.fw
firmware:       rtl_nic/rtl8168fp-3.fw

Hope, that helps.

1 Like

Awesome, thanks for this - the cards are fairly cheap, so I’ll grab one and try it out. I’m also on 4.6.1 :+1:

1 Like

let us know, how you get on with those, please.

Installed today.
It works fine with no issue, at 2.5Gb link speed.
Hurrah !

The specific card I’m using is in the M.2 WIFI slot of a DELL 3050 Micro - the Ethernet port fits perfect into the Serial port blank on the back of the case :+1:

Note that the card has to go in the M.2 WIFI slot because this is a KEY A M.2 slot.
You cannot install this card into a normal M.2 SSD NVMe slot because those slots are KEY M M.2 slots. Even though both slots are PCIe x2 they are slightly different physically because the KEY A slot also has pins for USB.
I had to enable WIFI/Bluetooth in the BIOS to make the slot physically active, it didn’t detect anything with those settings disabled.


EDIT : Actually I’m on 4.5.8 not 4.6.1…

1 Like

@Nom great news! Glad to hear it worked, and interesting about the installation process for that.

I think between 4.5.8 and 4.6.1 nothing at the kernel level changed, only some code fixes a few levels up, so if your version works for that, the next one up should have as well.

1 Like