Time Machine backup not working


I installed new rockstor to test how it is working.
Configured SMB time machine share, using instructions from this chat: Migrating time-machine from AFP to SAMBA

Still get this error in macOS side, macOS version is latest 12.0.1.

Mountpoint /Volumes/.timemachine/rockstor._smb._tcp.local./6707F575-C7FD-4F63-832F-2CDE3B5B46DA/backup does not support required Time Machine capabilities!

Should TM backups from macOS Monterey work with Rockstor?
Rockstor version is 4.0.9-0

1 Like

Hi @jukkaforss, and welcome!

Thanks a lot for reporting this issue… The Time Machine compatibility is always tricky to test for us due to limited and difficult access to Apple hardware; reports such as yours are thus extremely helpful to keep up-to-date.

A quick question to rule out a possible issue related to macOS migration. Was this Time Machine backup setup and working well in a previous macOS version or this on a brand new machine and thus a first time setup of that Time Machine backup?

From that error message, it seems Apple might have updated the requirements for Samba support so we’ll need to see what is needed and once that is figured out we’ll do our best to implement it. Maybe someone on the forum has come across that and know what needs to be updated? That would save a lot of time and be greatly appreciated!

Thanks again for the report, hopefully the move that seems to have happened with regards to Time Machine requirements is well documented as that will make everything much faster.

1 Like


I am new in RockStor, so this is new time machine share.

These are lines in console searched backupd during time machine backup try.

default 15:45:41.723562+0200 NetAuthSysAgent Mount URL: request 13DE983C-AD8E-4C87-9F89-C79765B1413C from backupd (304)
default 15:45:41.723634+0200 NetAuthSysAgent URL = smb://imac@rockstor._smb._tcp.local./backup
default 15:45:41.850936+0200 NetAuthSysAgent server smb://rockstor._smb._tcp.local./backup
default 15:45:41.873126+0200 NetAuthSysAgent URL = smb://imac@rockstor._smb._tcp.local./backup
default 15:45:41.873141+0200 NetAuthSysAgent Mount point = /Volumes/.timemachine/rockstor._smb._tcp.local./B3D65362-8AF3-48F7-B07D-FE49ECD358A3/backup
default 15:45:45.445467+0200 NetAuthSysAgent Reference added to MechType “<NetworkAuthenticationSelection: SPNEGO, admin@\rockstor.local cifs@rockstor.local spnego: yes>” with label “fs:/Volumes/.timemachine/rockstor._smb._tcp.local./B3D65362-8AF3-48F7-B07D-FE49ECD358A3/backup”
error 15:45:45.447560+0200 backupd Mountpoint /Volumes/.timemachine/rockstor._smb._tcp.local./B3D65362-8AF3-48F7-B07D-FE49ECD358A3/backup does not support required Time Machine capabilities!
default 15:45:45.463057+0200 com.apple.prefs.backup.remoteservice UNIX error exception: 17
default 15:45:45.469873+0200 com.apple.prefs.backup.remoteservice UNIX error exception: 17
1 Like

From samba logs, looks like an access issue.

[2021/11/08 18:39:23.214254, 3] …/…/source3/smbd/smb2_server.c:3863(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[5] status[NT_STATUS_INTERNAL_ERROR] || at …/…/source3/smbd/smb2_server.c:2017
[2021/11/08 18:39:23.216112, 3] …/…/source3/smbd/smb2_server.c:3863(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_ACCESS_DENIED] || at …/…/source3/smbd/smb2_create.c:334
[2021/11/08 18:39:23.216446, 3] …/…/source3/smbd/smb2_server.c:3863(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_FILE_CLOSED] || at …/…/source3/smbd/smb2_server.c:3224

1 Like

Got it working, needed to change access rights to 777, so also others read/write/exec.

Now it create sparsebundle file.
Backup still not work perfectly, but I look in that bit later.