Transferring files through SMB/SFTP What am I doing wrong?

I’m having trouble transferring files through SMB and SFTP which might be due to different naming scheme of my files and folders but not sure. The copying just ends abruptly.

It’s obviously my fault for naming weird but I don’t know the rules/conventions for naming in Linux. The files worked/copied fine in Windows. Can someone help me out here with how to change names so things can run properly. Is there a easy tool to find messed up names? I have 5TB of stuff and it’s going to take forever if I just go through folder by folder.

@DAIGURENMARKX a belated welcome to the Rockstor community to you. Not much help I’m afraid but there is an issue with transferring files with ‘:’ in the name via SMB. I recently saw this myself, however the gnome desktop file manager informed me of the problematic files so I could change them as I went. Also there is an old linux program called Detox that is able to change problematic chars in file names but I have never used it and it would certainly be over kill to mount your data non-natively and run such an old program. If you could work out the problematic characters or character maybe you could within your windows os find and replace the problematic chars in those names.


Thank you. I’ve been trying to look for characters that aren’t compatible. Couldn’t detox work with ntfs-3g? Using that to mount on Ubuntu Mate is how I tried transferring through SMTP. So how do you get that information in gnome transfer, it will just be easier to do things manually if I can find them?

So I got most of the content copied. Verified some files. But I can’t seem to copy this 1TB of anime. The error comes up as "The folder “folder name” cannot be copied because you do not have permissions to create it in the destination. Which is odd because I copied all the other folders through the same SFTP process.

Copying the individual episodes in those folders gets the error “Invalid reply received”. I don’t know what could be the problem with the filename because brackets were accepted when the other files were copying.

I am so close to all of this being setup but errors keep coming.

@DAIGURENMARKX Maybe the file begins with a space or something like that.
Oh and I think by SMTP you are actually meaning SFTP - for Secure File Transfer Protocol where as SMTP is another well known acronym that stands for Simple Mail Transfer Protocol.
Just check the file names carefully again and make sure there is sufficient room etc.
At least your nearly there now, and moving to more cross platform compatible naming is bound to be a good move.

Thanks. The files don’t seem to have spaces at the beginning. They start off with brackets though.

And yes. I don’t know how SMTP got stuck in my head. I meant SFTP.

Edit: A restart and using Samba seems to be copying for now. Also is there a reason why Samba and Bootstrap turn off every reboot? I have to go back to the browser and turn it on everytime I shutdown/reboot. I’d prefer not to have to do this since the rest of the users are going to be using Windows.