Trouble with Logitech Media Server

I recently observed that the LMS wasn’t responding correct when I added or removed media-files from the media directory. It wasn’t displaying all the settings-pages correctly either. So I tried to restart the LMS from my servers Rock-on page. The result of this was that I no longer could access the LMS-page. At that time I wasn’t running the latest Rockstor version, so I upgraded to the latest (3.9.2-47) but the result is the same. I’m not able to access the LMS-page, on my Rock-on page the status of LMS is “running”, I have also tried to uninstall the LMS and then reinstall it?!

The result is the same, it acts as if the LMS is not running or not installed.

Thanks in advance!

Hi @Jorn_Normand, sorry to read you’re having trouble with this rock-on. I’m not a LMS user myself but I’ll try to help as best as I can nonetheless.

First, and to put away any misunderstanding, do you confirm you are using the rock-on named “Logitech Squeezebox”? The reason I’m asking is that we seem to have a submission for an allegedly updated version on our github repository by @jfearon (, which is giving me some trouble upon a quick test.
The current “Logitech squeezebox” rock-on, however, installs fine and I can access the webUI without problem, so even if it’s old it seems like a working solution while we get a newer LMS rock-on situated.

To get back to the issue you’re having, could you describe what you’re experiencing? You mention you could uninstall and re-install the rock-on, but what happens exactly when you click the “Logitech Squeezebox UI” button? If you get a specific error page that may be helpful.

If Rockstor shows the status as running, this means it detects the container as up and running, which should be confirmed if you run the following command:

docker ps --filter name=logitechsqueezebox
CONTAINER ID        IMAGE                          COMMAND                  CREATED             STATUS              PORTS                                                                                                      NAMES
cb7322b9cb28        tdeckers/logitechmediaserver   "/usr/local/bin/bo..."   10 minutes ago      Up 10 minutes>3483/tcp,>9000/tcp,>3483/udp, 9001/tcp,>9090/tcp   logitechsqueezebox

Let’s see what you have with this and then we can adapt from there.

Hope this helps,

The result of the command is:

Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.32/containers/json filters=%7B%22name%22%3A%7B%22logitechsqueezebox%22%3Atrue%7D%7D: dial unix /var/run/docker.sock: connect: permission denied

My bad, I forgot about root requirements for this command. If you are using Rockstor’s System shell (Shell-in-a-box service), you need to first elevate your permissions if you’re logged in with your regular user. In the example below, the user test is my regular Rockstor user I use to log-in the webUI, so I need to do:

[test@rockdev ~]$ docker ps                                                                                                                
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.
sock/v1.26/containers/json: dial unix /var/run/docker.sock: connect: permission denied                                                     
[test@rockdev ~]$                                                                                                                          
[test@rockdev ~]$ su                                                                                                                       
[root@rockdev test]# docker ps -a                                                                                                          
CONTAINER ID        IMAGE               COMMAND             CREATED             STATUS              PORTS               NAMES              
[root@rockdev test]#                                                                                                                       
1 Like

I’m unable to elevate my permissions, I am logged in with the admin-account created during install but when I try to run su I get “su: authentication failure”. I havn’t forgotten the admin password I created during install, but that password isn’t the one the system want’s?! I have a couple of other users created on the Rockstor-box but none of those passwords does any good either.

Hi @Jorn_Normand,

Can you try this instead:

sudo docker ps --filter name=logitechsqueezebox

If it asks for a password, that password is for the account you’re logged in as.

The reply to this command is:
Admin is not in the sudoers file. This incident will be reported.

Admin by the way is the user created during install, since this is not a user I have created myself after install?!


Are you able to login as root? and run

docker ps --filter name=logitechsqueezebox

1 Like

Nope, the password for I created at installation is not valid as root-password…I believe that this might be the right moment to take the server down and try to recover the root password or do a re-install

OK, after some time I finaly got around and reinstalled my server. I got it back up and installed LMS. It worked like a charm!
I then got my music library back on to the server and updated the library, it was fine for a couple of hours. Then I tried to open the UI and the site wouldn’t load properly. I tried to restart LMS and now I’m back to square one! It looks as if LMS is running fine, but I’m not able to enter the UI. When I check the docker status with the command:

docker ps --filter name=logitechsqueezebox

the result is:

ce0cf084e2c0 tdeckers/logitechmediaserver “/usr/local/bin/bo…” 11 days ago Up 3 hours>3483/
tcp,>9000/tcp,>3483/udp, 9001/tcp,>9090/tcp logitechsqueezebox

So as far as I can understand the system should be up and running, but it’s not!

Hi @Jorn_Normand,

Please try pulling the logs for the docker container in question:

docker logs --tail 50 logitechsqueezebox

Also, try attaching to the container and running top or ps to see what it’s currently doing:

docker exec -it logitechsqueezebox bash

Let us know how you go, and what the logs come up with.



1 Like