Trying to use letsencrypt to get a certificate for owncloud rockon


I have been waiting for the for some time now. And since today i descided to do my best to get it working manually.

I have tried to follow the tips and the tutorial from sitic in the issue tracker but without any success. I get an error message about the client lacks sufficient authorization. Ive tried different variations and i have tried to use both the official owncloud rockon, and the default one but with the same error.

Do you think it would be possible to use letsencrypt to generate a valid certificate for the official owncloud rockon while waiting for the issue to resolve, or should i simply wait for it get implemented?

Any ideas?

I actually got it to work!
I followed the last updated steps from sitic in and the reason why it did not work with my first attempt was my port forward settings.

I had to port forward my rockstor instance (not the default port to my owncloud) to get a valid cert. Afterwards i could change back to only expose the owncloud docker port 8084.

Finally a beautiful little green padlock in the browsers upper left corner :slight_smile: