Unable to Access Management GUI

Hello everyone,

I was running into an issue where every once in a while, my Rockstor machine would no longer let me access the management GUI. The only way I could get it to work again was re-install. After this happened on 2 different occasions I then went digging through this forum and found some troubleshooting steps which were able to help me fix my problem. Ill discuss below, hopefully this helps others.

My DHCP server was giving my Rockstor pod a new IP but the nginx config file was not aware and would then fail every time I tried to start the Rockstor service. By changing my interface IP back to the one I used during inital setup everything would work again. This issue can be avoided completely by using a static IP which should be used for a server anyway.

After leaving the machine turned off for day or two and then booting into rockstor it would leave me with a “server is unresponsive” error whenever I would try to access the GUI.

I could succesfully ping the server and could ssh into it. So determining that my physical network connections were correct, I dug into the software side.

After checking the status of the “rockstor” service I could see that the nginx would fail on start up.

Here is the expected output when everything is working:

Here is the output when the GUI is unresponsive:


I tried to manually restart the nginx service by using the command the Rockstor service uses to start it:

     /usr/sbin/nginx -c /opt/rockstor/etc/nginx/nginx.conf

And it failed telling me that it was unable to start the web service on “”

This was weird as my IP was actually “”

So I manually changed my network interface config file (/etc/sysconfig/network-scripts/ifcfg-eno1) to have the IP “”

After restarting the rockstor service I was able to log onto the management GUI again!!


The IP the nginx config file was referencing was the IP my machine had when I had initially installed Rockstor.

By turning off the machine for a couple days upon reboot it would receive a new IP from our DHCP server.

However the nginx config file did not reflect this change and it kept the old IP, this is what caused the mismatch and therefore was not allowing the service to start.

By changing my IP to a static one with the same address as I originally had, I was able to successfully get the rockstor service to start again.


Thanks for detailed report @bkelly, really helpful! rockstor-pre service updates nginx config if necessary, but it must be improved by refreshing the network state. Here’s the issue for this

Please tell me if I am unable to access management in the case, if I use a proxy and my ip is not real?