Unable to boot into 4.8 kernel

I recently installed rockstor, in a round-about way. I had tried the latest ISO, but it would error, I started working backwards through the ISOs and then after a couple decided to go back one year. I was then able to get into the installer and get everything installed and working.

On my first foray into the OS, it wanted to update, and I let it.
It did it’s thing and rebooted.
Now whenever I boot into the 4.8.7-1.e17 kernel, it panics and stops.
I can still use the 4.3.3 kernel image, but now it complains that the kernel is wrong for this version.

Screenshot of the issue:

@rocksthor Welcome to the Rockstor community forum.

Rockstor uses an unaltered elrepo kernel-ml (main line), just adding here as this may help with searching for what is tripping up in later kernel version on your hardware. There are plans to upgrade the default Rockstor kernel version soon but not sure when this is due.

Hope that helps.

The UI complaint about kernel version is from a simple numeric match to inform you of the mismatch version number from what is expected.

This morning, fed up, I nuked it all out and used the latest version. It had been giving me errors regarding anaconda and other stuff, but I don’t know how to access logs from the installer. Let alone save them. The error just gave me the option to quit.

I tracked down that the KVM of my system was not enabled. Turning this option on, seemed to stabalize. I was able to get further into the installation. However once it got to the rockstor part of the install, it choked again and I got another anaconda error.

I figured it had done enough of the install. So I rebooted. Then immediately did a yum update/upgrade rockstor.

Everything seems to be working atm. But I am nervous as hell. Getting this system running was not easy and I question it’s long term reliability. O_O

@phillxnet quick question maybe off the topic.
Anyone tried to upgrade to any newer kernel version (>4.8.7-1.el7.elrepo.x86_64) by simply using their rpm packages (e.g 4.9 or 4.10) ? :fearful:

@glenngould I haven’t gotten around to trying any newer versions myself but apart from that warning and some code that will try to revert the default to the official version it’s definitely worth a try. Rockstor simply copies the vanilla kernel-ml kernels into it’s repo’s so nothing special going on really; apart from the version check and consequent warning.

Let us know how it goes.

@rocksthor What is the hardware specification you are having install troubles on, and have you looked at the Pre-Install Best Practice (PBP) entry in the docs. You may have some dodgy RAM or just not enough of it: see also Minimum system requirements. Agreed you want a smooth install, if nothing else but for re-installs. Best to track down the issue if you can as it will only bite you back later; unless of course it’s a hw specific bug that gets fixed upstream.

The motherboard is: ASUS M4A78L-M with an AMD Phenom III Black processor (AM2+)
My RAM is only 4GB yes, but it has not been an issue at all, and did not prevent the installation of Rockstor.
There was a bug that was repeatable over several versions of Rockstor, and was not present back in the January 2016 release. However, as I said, the big issue that seemed to hold things up was KVM (virtualization) settings in the BIOS.
I could go back and re-install again and try to provide that info, but I have a stable system atm and I want to work with it longer. I’ll create backups.

@rocksthor I’ve managed to reproduce a very similar issue on a KVM virtual machine instance to your original kernel 4.8.7-1.e17.elrepo.x86_64 boot problem so pasting the details here for context, ie as another example of a 4.8 kernel boot problem.

This install was an mdadm root arrangement as per our:
from way back and after a global package update the given kernel boot results in:

As per your original report this install also booted OK in 4.6.0-1.el7.elrepo.x86_64.

Shares your ‘installed from old iso’ then global update scenario, although the Rockstor components in this install are all from source as it is a ‘test bed’ for some drive categorisation work I’m currently doing.

I’m working on other elements of Rockstor for now but will post back here if I managed to take another look at my instance of a 4.8 boot failure.

By the way, nice find re:

Thanks for reporting your findings and work around.