Unable to boot Rockstor ISO image from USB

So I want to give Rockstor a try, but I’m not getting anywhere with it because I cannot get the install image to boot.  I’ve tried the usual “dd the image to the drive” approach that always works and liveusb-creator as well, but no system I have recognizes the result as a bootable drive.  Clearly there’s something different about this image; anybody have an idea of what it is that I’m missing?



This is a big pain point, but I can tell you for sure that Rockstor cannot be installed from USB right now. You are not missing anything. It just doesn’t work. Rockstor is a customized CentOS 7 minimal ISO and at this point I am not sure if the problem is in the base iso or in our customizations.

Other users have asked me in the last few weeks and so I tried all known methods to create a bootable usb, but with no luck. Since many of us don’t have spare cd-rom drives just for installation, I agree that it would be nice to just dd and install via usb. We are not there yet, but hopefully soon.

I’ll update this thread with future updates.

OK, thanks for the update, that’s good to know.  FWIW, a quick note in the install documentation might help save others from having to go through the same pain.

Meanwhile, maybe I’ll see if I can’t pick up a cheap cdrom drive from somewhere.  I vaguely remember how to burn one of those quaint round optical thingies…:slight_smile:

I hope you haven’t bought a cdrom drive yet. I am able to create a USB friendly ISO. We’ll be releasing an update in a few days and I’ll create a new ISO along with the update. If it all works out, may be you can divert that cdrom money and make a donation :slight_smile:

A new iso(3.5-5) is now available which is USB installable. I’ve also updated the documentation. Download it and you should be all set!