Unable to connect the the web Ui

I have tried to installed it and get it running in the past few days with small progressions but still cannot access the WebUI. I have checked I’m using https i have checked the systemctl -l rockstor and it says its running and loaded. I have tried running /opt/rockstor/bin/initrlck. All with no luck. I have been looking for the answer but not having too much luck. Im sure its something simple but this is my first time trying to set something like this up that isnt just on local host.

Please help.

@Plazmatic4 Welcome to the Rockstor community.

I’m assuming you are using our new installer for the v4 “Built on openSUSE” version.

Does your install progress as per the howto here:


And if so what is the output of the myip command at the end? And after the first reboot?


It does sound like all is well so this may just be a network issue. You machine is presumably attached to your network via a cable. Rockstor doesn’t, at least yet, support wifi connection setup via the Web-UI.

You can also test the network access from a client machine (laptop/desktop) by doing a “ping” command to the number in the “myip” output.


where the number is actually what “myip” said it was.

This helps to test the connection between your client/laptop/desktop machine and the Rockstor machine.

Hope that helps and let us know what your find the output of the myip and ping commands to be. For access to Rockstor the client machine must be on the same network.

You may also have a browser plugin that auto-rejects / blocks self signed web pages. Rockstor uses a self signed certificate as it’s better than not using https. The end of the above installer guide explains this.

1 Like

So It finish the install and I even updated it as per the on screen instructions and reboot. I am given an actual IP that fits my local network 192.###.1.207 or something like that. I would post it but I forget the exact address and Im not home to grab it. The machine is attached to Ethernet via a switch. Could that be the issue? I haven’t tried pinging it yet Ill do that once Im done school and work for the day.

For the browser I have tried different devices and browsers, It always times out.

Side not is it at all possible to connect to it from an outside network?

@Plazmatic4 OK, so let us know what the ping returns when you get the time.


Potentially but it’s outside the scope of this thread currently. And needs some preperation on your router to likely port forward the ports you want to be exposed to the internet. Lets get your local access sorted first.

If the switch is faulty or there is an incompatibility there somewhere. But if the machine is getting a local IP then it would seem all is OK on that front. The ping should confirm this however.

Still not sure what this might be. If all the rockstor services look to be OK and this is a fresh install, that has picked up an IP ok, then it’s still a bit of a puzzle. Does the machine have more than one lan/ethernet socket. It may be that one gets an ip but somehow the system attaches then to the other that is not setup appropriately.

Rockstor use Network Manager under-the-hood. Take a look at the output of say:


executed as the root user on the Rockstor machine.

Bit of a puzzle currently.

1 Like

A curious one indeed.

Seems from your posts that the Rockstor device is receiving a DHCP IP address, presumably from your router, and you are able to log in on the Rockstor device and use the myip command.
I’m guessing that the ### in your post above will be 168.

Are you able to ping other devices in your network from the Rockstor device? The router would be a good example for instance.

Also might be worthwhile clearing the browser cache as this has caused me grief before with things like this.

Also, once you have this resolved I’d recommend making your Rockstor appliance IP address static (alternatively use a DHCP reservation in your router). I find a static IP better for servers… but that could just be me :slight_smile:


Thats A good note. I wont be home for another 9 hours but ill try that as well and let yall know

1 Like

Ping was all good and I was able to connect tonight

. . .

No idea as to what changed