Unable to increase size of share

Since installing 3.8-3, I don’t seem to be able to increase the size of shares residing on my pool.

What I have done is make a RAID5 pool on 3 500Gb disks.

Made a share using all the available space 931GB.

Copied some files to the system.

Added a 320GB disk to the system, and added it to the pool.

Balanced the 4 disks.

Now I’m trying to increase the size of the share, but I get an error message:


" btrfs qgroup limit: invalid option – ‘1’ usage: btrfs qgroup limit [options] |none []
Limit the size of a subvolume quota group. -c limit amount
of data after compression. This is the default, it is currently
not possible to turn off this option. -e limit space exclusively
assigned to this qgroup "

I have resized shares in the earlier 3.8-2 without issue.

I followed the steps you detailed here but could not reproduce the problem. Could you do the following?

  1. Make sure you are running the right kernel. (3.8-3 fails to show the warning if you are not). uname -r command will give you the answer and it should be 4.1 kernel. If you are running the wrong kernel, just reboot and check again. A single reboot should fix.

  2. follow the instructions as per the UI and send the logs over to support@rockstor.com.

I had tried with a reboot, sorry I didn’t mention that.

uname -r gives: “4.1.0-1.el7.elrepo.x86_64”.

I do think I have fixed it though. I deleted the share completely. When I recreated it, for some reason it created a 1TB share, allthough I asked for a bigger share. But this time around I was able to change the size afterwards, so that it now uses all of the pool.

I am putting data onto the share now, and will try to resize again later.

Today I have been copying data to and from the share, and have resized it a few times, without problems.

Whatever the problem was, disapeared when I deleted the share and then created it again.


Well there is a problem with the resizing code somewhere.

After converting my pool to RAID 6 yesterday, I received my mSSD later that day and decided to make a fresh install and then import the pool / shares into the new install (The mSSD works well, and sped up the rockstor installation (installed from USB and it took about 5 mins from start to finish), and Rockstor itself, nicely).

All this worked well enough, but the share size on the pool was bigger than the size available on the pool after conversion, so I tried to reduce the share size, and got exactly the same error I got in the original post.

No problem, as this is a test, and there was no data of importance on the drive. So I deleted the share and made it again, and now I could resize.

But since I have decided to start using the NAS for real data (its pretty much setup as I want it now), it has me a little worried that the resizing doesn’t seem to work all the time. I’m going to be adding and replacing disks a couple of times, before the NAS is completely finished. This will require some resizing, and it needs to work.

Are there commandline operations I can use if the web interface errors out?
I have tried searching for answers, but its like finding a needle in a haystack, for a Linux / Centos newbie…