Unable to install Pi-Hole RockOn

I just installed a Minecraft Server and Nextcloud RockOn. Now I wanted to try out PiHole. I created a share on my root SSD but after two attempts PiHole refuses to install.
Any ideas why?

I’m running into the same set of issues. The Rockon is failing to install and get nothing back.

Hi @Siren,
Hi @hedgie, and welcome to the community!

Sorry to see you’re both having issues. I always dislike when it’s like that, but I just tried installing the Pi-hole Rock-on on real hardware and it worked well, without any issue. I’m hoping it’s just some misconfiguration somewhere. For this reason, I’m going to ask you for as much detail as you can possibly think.

  1. What version of Rockstor are you using? You can verify by running yum info rockstor.
  2. Can you describe what you observe when trying to install the Pi-hole Rock-on? When you click on the “Submit” button at the end of the Rock-on install wizard, what happens? Do you see the “installing” rotating gear? Does it disappear and nothing happens? Do you see any error message?
  3. You can also check on your machine whether the pi-hole docker container (created by this Rock-on) has actually been created or if it has failed before that. What does the following return: docker ps -a --filter name="pi-hole"?
  4. If the pi-hole container has indeed been created, have a look at its logs and paste them here: docker logs pi-hole

Hopefully this will help put us on the right track to identifying what is happening here.

1 Like

Hey Flox,

I’m on read hardware too. I can five you the specs. But as for the pihole stuff, Rockstor is on v 3.9.2. If I click submit I do get the gear processing the install. I’m actually dealing with permission issues because I can’t connect via ssh as the root user. So can’t get my normal user into the sudoers file.

Actually I spoke too soon. Got in as right via ssh. No counter details at all for pihole after running those commands.

  1. Version 4.0.8

  2. It, after pressing submit, just tells me to wait and that it could take a while. Then it takes ma to the “Installed” page where there is no Pi-Hole.

  3. From that being the only output line I guess there is no container…


Hope that helps :slight_smile: