Unable to remove Rock-on

I have been working on getting my Rockstor server to do more of the tasks I have that require a computer to be active.

So I installed the Squeezebox Rock-on to try and make it the server for my trusty old Squeezebox Classic.

Installation went fine, and I let it sit there, to come back later and do some more configuration and testing.

But later when I came back, I had to reboot the machine, to install a new disk (I am in the progress of going from RAID 6 to RAID1, and need never bigger disks). This all went well, and the disk is being added as we speak.

But. the Squeezebox Rockon was not active:

Trying to start it does nothing. The bar goes from on back to off after about a second.

Hitting update gives this (after some time):

Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 105, in post
self._create_update_meta(r, rockons[r])
File “/opt/rockstor/eggs/Django-1.6.11-py2.7.egg/django/db/transaction.py”, line 371, in inner
return func(*args, **kwargs)
File “/opt/rockstor/src/rockstor/storageadmin/views/rockon.py”, line 169, in _create_update_meta
handle_exception(Exception(e_msg), self.request)
File “/opt/rockstor/src/rockstor/storageadmin/util.py”, line 49, in handle_exception
raise RockStorAPIException(detail=e_msg, trace=traceback.format_exc())
RockStorAPIException: [‘Cannot add/remove container definitions for Plex as it is not in available state. Uninstall the Rock-on first and try again.’, ‘Traceback (most recent call last):\n File “/opt/rockstor/eggs/gunicorn-0.16.1-py2.7.egg/gunicorn/workers/sync.py”, line 34, in run\n client, addr = self.socket.accept()\n File “/usr/lib64/python2.7/socket.py”, line 202, in accept\n sock, addr = self._sock.accept()\nerror: [Errno 11] Resource temporarily unavailable\n’]

Which to me is mostly meaningless. It looks as if it thinks I’m trying to remove Plex or something?

I have not, and Plex is running and works.

I have tried to Uninstall Squeezebox, to try and reinstall, but nothing seems to happen

It seems I hit a bug.

What info do you guys need to get me going?


It seems I am also unable to stop the Plex service.

Well a reboot seems to have solved it.

At least both Rock-ons are running now.