Unifi Controller RockOn issue

I’ve installed the Unifi Controller(not the linuxserver.io version) on my Rockstor Nas unit running version 3.9.1-0 and after install the controller starts and I can launch the wizard to start configuring the controller and shortly after I start typing in the config info the RockOn page of the Rockstor Nas shows that the Unifi Controller is off and Current status: unknown_error. After this happens if I try to turn the controller on through the RockOn page it shows pending start and then goes back to showing off and unknown error again. I’ve tried uninstalling and reinstalling and get the same result every time. The controller is stored in a share I created just for RockOns. I’ve also tried creating another(that makes 2) RockOn share and I have uninstalled from RockOn share 1 and reinstalled on RockOn share 2 and get the same results as well. Rebooting the entire NAS also doesn’t resolve the issue. I’ve looked through the system logs and don’t see anything that might reference what is happening to cause this. This is the only RockOn on this system so there shouldn’t be a port conflict. Thanks in advance for any help offered to resolve this.

@dcbailey Welcome to the Rockstor community.

From the sounds of it you are using the RockOns share as both the Rock-ons-root:


But each Rock-on should in turn have it’s own set of one or more shares for it’s config/data requirements. It may be that you are trying to use the same share as both the Rock-ons-root and as config/data share for a Rock-on. This is likely to break/run into difficulties, hence the recommendation that a dedicated share is created for each separate purpose. And the linuxserver.io looks to have a “Config Storage” share requirement. The mouse over tool-tip reads:

“Choose a Share for Unifi Controller. Eg: create a Share called unifi for this purpose alone.”

So you need a share specifically for the Rock-ons-root which holds all the docker images for the various Rock-ons and another for the unifi config volume.

Hope that helps.

1 Like

I have 2 shares for RockOns…one called RockOn-config(10GB) and the other RockOn-Data(60GB). RockOn-config is the root for all RockOns. When asked during install of the Unifi RockOn I chose the Data share. As stated previously it doesn’t appear which share I install it on the behavior is the same. I may be missing something as on install of the Unifi controller it doesn’t ask for a separate share for config vs data.

@dcbailey Re:

OK, so that’s good as you have separate dedicated shares.

One for Rock-ons-root as per doc reference.
And one for the Unifi RockOn (RockOn-Data(60GB))

But not that the latter shouldn’t be used by any other rock-on either. But you state you have only this rock-on installed.

No, the linuxserver.io Unifi Rock-on only uses a single share. But some other rock-ons require multiple shares, often separating config and data.

I just wanted to establish your share use and that you were not re-using your Rock-on-root share as a Rock-on specific share, or vice versa, as that often just breaks things.

We need someone who uses this Rock-on to chip in here really.

Thanks for the input. As I mentioned I’m not using the linuxserver.io version of the unifi RockOn…just the regular Unifi Controller RockOn and it only ask for 1 share location during install which I chose as my Data share. Hopefully someone will have an idea of what is causing this.

and yes this is the only RockOn installed

I’m not a user either, but maybe the docker logs will help (it depends on the image itself, sometimes). From a command line session, I would run:

journalctl -f

… this help print most system logs (including the docker ones) as they come. You can then start the rock-on, watch the logs and see what is coming up right before you see it turning itself off.
Sorry I can’t help much more than that as I’m not familiar with that rock-on itself and can’t really test much of it as I don’t have unifi hardware. Hopefully that will help a bit.