Unknown internal error doing a GET to /api/pools/3/shares/

Is anyone else getting an error when clicking on their pool?
I noticed this after the upgrade to 3.9.1.

To reproduce this I go to Storage>Pools
Click on my pool, tank, which is a raid1 pool.

The error text never actually loads so the only error I get is:
Houston, we’ve had a problem.

Unknown internal error doing a GET to /api/pools/3/shares

@mkeith83 A belated welcome to the Rockstor community.

Have you tried closing your browser/browser tab and re-opening as recently the api for pools and disks was changed from names to numbers, maybe there is some older code still at play in the browser. Also a Rockstor reboot might shed some light on things. But I haven’t seen that particular error here. Did you upgrade via the Web-UI?

@phillxnet Thank you =)
A reboot did fix the issue. This was a system that auto-updated as part of the stable update path and I hadn’t logged in in a while, but everything looks to be working now =)

Thank you.

@mkeith83 Thanks for the update and glad your now sorted.
The api url changes that lead to this were big changes but important ones that should clear the way for new features and capabilities so had to be made in the end. As a consequence this temporary side effect was difficult to avoid.

yea no worries, I should have tried rebooting in the first place =)