- Unknown internal error doing a POST to /api/rockons/update

Hi. I am trying to create a home storage solution with Rockstor and having some issues. I have installed under ESXi with the recommended resources assigned.
Brand new installation. Found some steps to create 4.0.4 installer using kiwi then upgraded to 4.0.7. Created disk pool and a couple of shares, one for rock-ons.

When I try and update my rock-ons, I get the error:

I have tried a couple of times and also rebooted the system. The rockons page then tells me the service isn’t running even though the switch is still showing “On”.

Note I am not much of a system admin so be gentle with me.

@iain0404 Welcome to the Rockstor community.

Well done. any comments on how we could improve this process would be welcome given you are now among the increasing number of successful self-builders. And please done be shy in chipping in to help others who have struggled with our current instructions in this area. This all helps to see where our docs on this can be improved.

You are likely experiencing an upstream issue first reported by @Emmanuel_perez and confirmed by @sanderweel with docker on systems with IPv6 disabled. See the following forum post by @sanderweel for details.

This has now been fixed upstream and we are awaiting it’s appearance in Leap 15.2/15.2 which is used in the new Rockstor 4 “Built on openSUSE” variant.

However for the time being you could following the work-around (downgrade docker) presented by @sanderweel and confirmed again by @Emmanuel_perez with an @Flox investigation there after.

Bit of a pain this one but at least an upstream fix is in the process of filtering it’s way down to our upstream (Leap 15.2/15.2).

Hope that helps.

Well done. any comments on how we could improve this process would be welcome

Thank you Phillip. To be honest it is more complicated than I was expecting or am used to. I had to run up a complete new openSUSE client in order to install and run the kiwi commands, but after that the process went as advertised.

However for the time being you could following the work-around (downgrade docker)

I did that (although initially it had issue accessing the repos) and it made me also downgrade containerd and runc as well. However, I still get the same problem of Unknown internal error. And after a reboot, in case that was required, I get the message about the rock-on service not running, so I need to flick the switch off then on again.

EDIT: and those packages are definitely downgraded because I have the flashing radio symbol in the top bar which tells me I can upgrade them all.

Yes a pain, any further thoughts?

@iain0404 Re:

Im still not sure what’s going on here I’m afraid. So as a potentially over-the-top procedure to hopefully get you up and running again, now you are on the older docker to rule out that know issue, you could try re-doing your rock-on-root setup. This has been known to resolve (work around) some tricky failures. Essentially you disable the rock-ons service (off already for you anyway for unknown reasons) and setup a new rock-on-root subvol by a different name to your existing one:


Then select this new ‘clean’ Rock-ons-root’ for the Rock-ons system via the Rock-ons spanner icon and thereafter be able to re-enable the Rock-ons service. This should give you a new start and if you have done as indicated in your prior Rock-ons setups and used dedicated config & data subvols for each rock-on, re-installing each rock-on should put that rock-ons exactly back where it was config & data wise.

If you still have dangling Rock-ons from the prior Rock-ons root you can use the instructions here:

referenced in the other thread I mentioned re the docker downgrade thing, to remove these ghost entries in the db before re-installing that rock-on.

The prior Rock-ons root can then be deleted, assuming you didn’t use it for any of the Rock-ons config or data store (highly un-recommended) previously.

This is a brute-force and obtuse method but if it gets you up and running again then great.

Hope that helps and I’m afraid this is all I can think of currently.


Thank you for your suggestions Philip, however nothing I have tried has made the slightest bit of difference. As this is a brand new system I even went as far as starting again from scratch with a clean install and I get the same outcome. I am afraid this had now proven too difficult for what I want so I am unfortunately giving up :frowning_face:

@iain0404 Yes, very frustrating.

So are you saying that you tried the docker downgrade and then rebooted and still had the same issue ?

Cheers. Otherwise if you are now done with Rockstor then another alternative open source DIY NAS option is open media vault. However they do not support well btrfs but that may not be a priority for you.

In order for folks to help more with specific issues it’s always best to provide log entries around the time you tried stuff and given exact details of the stuff you tried. This will be the case with any system you end up using.

Hope that helps and otherwise have a nice NAS journey and thanks for giving us a look.

1 Like