Unknown internal error when trying to install certain Rock-ons (i.e. Jellyfin)

[Please complete the below template with details of the problem reported on your Web-UI. Be as detailed as possible. Community members, including developers, shall try and help. Thanks for your time in reporting this issue! We recommend purchasing commercial support for expedited support directly from the developers.]

Brief description of the problem

Unknown internal error doing a GET to /api/rockons/devices/131?page=1&format=json&page_size=32000&count=

This “unknown internal error” occurs when I try to install the Jellyfin Rock-on. Oddly, for me at least, it only occurs with certain Rock-ons (i.e. Jellyfin, Emby, Plex). In these cases, the install wizard did not load. Only a blank pop-up screen appeared and the error message at the top of the page. The install wizard of the other Rock-ons seems to work fine – I have not tried the entire list though.

Detailed step by step instructions to reproduce the problem

Unfortunately, I do not know. I have followed the instructions on installing Rock-ons and creating shares in the documentation carefully. However, it might be worth mentioning that a “Houston Error” also occurred when I first switched on Rock-on in the Service Menu. It disappeared after I tried again.
My Rockstor version is 4.5.0-0. My OS is Open SUSE Leap Linux: 5.3.18-150300.59.106-default

Web-UI screenshot

[Drag and drop the image here]

Error Traceback provided on the Web-UI

No Error Traceback was displayed.

@Carl-Philipp Welcome to the Rockstor community forum.

I’m not entirely sure what’s going on here but there are some pending updates for you to be running the latest version. 4.5.0-0 was our first testing channel release for the current testing phase. Take a look at this forum post for more context on this:

We are now on Stable Release Candidate 3 (RC3) which is 4.5.6-0 from that same thread.

Also note that your base OS is now EOL at Leap 15.3, and although we are still, just about, managing to release for this OS version; our current target is now Leap 15.4.

Depending on the complexity of your setup, you may want to take the re-install route using our latest pre-build installers downloadable here:


And use a Leap 15.4 based one, the 15.3 based ones are included currently as a convince for those still having some issues with 15.4 hardware compatibility. The installers currently include the RC3 4.5.6-0 as of this forum post, as we are on the home run to releasing our next stable channel release. See the following GitHub Milestone for progress on that front:

You existing pools (except for the system pool as it will be overwritten) can be inported into the newer install if required. Just be very careful not to accidentally install over one of your existing pool members.

Alternatively you can zypper dup in place if you are familiar with that process, but that can be more complicated and we have yet to create a 15.3 to 15.4 counterpart to our:


Let us know where you are with this current setup regarding data/configuration etc so folks here on the forum can help with getting you onto updated. As you will then likely have less issues than with this earliest of testing releases. Plus we have made major build changes in the interim that are the future of how we are to be building and updating our main package from now on.

Hope that helps.


Hi @Carl-Philipp, and welcome!

@phillxnet already detailed it but I just wanted to confirm: your description (excellent, by the way), matches a bug that was fixed in Rockstor-4.5.4-0 so an update should fix it for you.

Let us know how it goes.


Dear Philip and Flox,

thank you for your quick and comprehensive response! That helps a lot. I already thought about the fix you mentioned in the new release after having read the release notes, but was not sure if it relates to this issue of mine – I am still rather a novice to this whole space of server knowledge.
I will let you know if/ when the issue has been solved.

Thanks again!


Sorry, it took me a while to get everything working. Everything works fine now. I started by simply updating to and Jellyfin finally worked. However, since I could not get NFS running, I decided to upgrade from OpenSuse 15.3 to 15.4 with the Rockstor version Everything runs very smoothly now. Rockons and Jellyfin work and so does NFS. Thanks again!