Update to 3.9.2-20 Samba share is browse-able but unable to open or copy files

My system auto updated to 3.9.2-20 and now I can see all my Samba shares from my Windows machines however I get error messages saying could not open files or copy files.Everything was ok until the update. It was running a scheduled monthly scrub this morning as well. I rebooted entire appliance gracefully, I can copy via SCP but trying to copy via Windows Share fails.

systemctl daemon-reload done
The following updates will be applied on rockstor:

Package Arch Version Repository Size

rockstor x86_64 3.9.2-20 Rockstor-Stable 15 M

Transaction Summary

Upgrade 1 Package
The updates were successfully applied

Could you please provide the whole error message seen on your windows client?
Also, provide a screenshot of you Samba shares page.


I tried from another laptop as well could browse but not copy or read files. WinSCP works fine.


Hmmm, haven’t seen that one before.
Apparently others have, and it appears common on larger file sizes, seemingly due to latency.
I can see that the files you’re attempting to copy are quite a lot smaller than those in the reports, which is perplexing.

One possible workaround for the time being is to run this in Powershell on client machines:

Set-SmbClientConfiguration -SessionTimeout 600

Alternatively, again on the client, you can try disabling SMBv2 and SMBv3

I’ve seen reports on this error regarding SMB signing, but I believe it’s off by default.

Finally, I’ve also seen reports that custom TCP frame sizes (Jumbo framing) can cause this if not supported by interim router hardware.
Check the MTU size on your primary network interface, IE:

[ root@rockout (pass 0s) ~]# ip address show eno2
3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether ac:1f:6b:1c:3f:8f brd ff:ff:ff:ff:ff:ff
    inet brd scope global eno2
       valid_lft forever preferred_lft forever
    inet6 fe80::af30:1d01:c193:b662/64 scope link 
       valid_lft forever preferred_lft forever

MTU should be 1500 or lower unless Jumbo frames are in use.

Beyond that, I’m out of ideas, hopefully somebody else can pick this up for you.

Thank you for the suggestions, I tried changing settings on the client side but nothing helps. It is something on rockstor itself, as it was working perfectly with no issues before. Is there some I can look at on rockstor samaba to see why I can browse but not read/write?

[root@rockstor ~]# ip address show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 62:33:34:64:38:37 brd ff:ff:ff:ff:ff:ff
inet brd scope global eth0
valid_lft forever preferred_lft forever
inet6 fe80::6033:34ff:fe64:3837/64 scope link
valid_lft forever preferred_lft forever


Your MTU settings shown are fine, honestly I’m out of ideas.
The most likely culprit is an upadted Samba package in the CentOS base repository.
You could try rolling back Samba?

Here’s a (long) one liner for determining which transactions intalled/updated which Samba versions, along with what else was installed/updated:

for transaction in $(yum history list screen | grep -oP "^\s+\K\d+"); do echo "Transaction $transaction:"; yum history info $transaction | sed -n '/^Packages Altered:$/ { s///; :a; n; p; ba; }'|sed '/^history/Q'; done

From there, you have two options.

Undo the latest transaction with Samba (Assuming none of the other installed/updated worry you):

yum history undo <transaction_number>

Find and roll back to the version of Samba previous to the one that was installed above.

yum list available samba --showduplicates | awk '{print $2}'
    -- find the version prior to the version installed above
    -- Assuming it's still in the repository!
yum downgrade samba-<oldversion>

I have the same error but I am able to duplicate on Samba and NFS. Copy a small files and it zooms by. Copy anything over 10 GB and the share times out and fails.

I am running an older version of RockStor at 3.9.1-16. It seems to just start happening. There has been no updates on the system. Any help on figure this out would greatly be appreciated.

Able to duplicate from my Linux Backup software to a Windows copy. At a loss.