Updating docker image

I just wanted to share something i found when trying to figure out how to update my sabnzbd docker image.
What i tried:
I tried uninstalling the rockon and reinstalling. Same version 1.2.3 :-1:
Uninstalling, rebooting the rockstor server then reinstalling: Same version 1.2.3 :-1:
Uninstalling, running the command “docker system prune” from ssh then reinstalling: Same version 1.2.3 :-1:

Last thing i tried was uninstalling the rockon then logging into ssh and run this command “docker rmi linuxserver/sabnzbd”.
The command will remove the image and all image cached items from docker. Then i reinstalled the rockon and now it’s version 2.0 :+1:

Perhaps this command should be part of the rockon uninstallation process.


I cannot test the following with sabnzbd, but emby can be updated using this way:
docker exec emby-server update

Simply reinstalling the rock-on with the intention to update would lead to the same (older) version of emby - just like you discovered with sabnzbd.

So maybe you should have used the docker command to get a newer version.

Kind regards

Thanks for the tip.
What i can tell from testing all that command does is to trigger a binary called update inside the container so it does not work for other containers that do not have it.
Also it will not update the main docker image.