Upgrading without NIC?

OK, got a problem. I just purchased an HPE ProLiant ML10 Gen9 system to setup a RAID10 NAS. I have four disks in the machine and a 16GB USB stick on the motherboard USB port for the OS. I tried every release starting with 3.9.1 working backwards to get it to install. 3.8.15 worked like a charm, except it does not see the NIC. No big deal, I’ll upgrade with the 3.9.1 media later. The thing is, I cannot figure out how to upgrade it. The only thing I have done since installing is to tune the ext4 filesystem (why is this not JFFS/JFFS2 for my USB install?) to run better on USB flash. I did this by changing the mount parameters to “defaults,noatime,data=writeback”. Beyond that, nothing has changed.

So how do I upgrade? I read another post here stating that the newer Rockstor images have a bug on HP systems due to CentOS. This was causing me to get an error along the lines of “/dev/root no such device” after booting. Gentoo runs FINE on this system, but it would be high maintenance for a NAS, so I am trying to avoid that.

@Sephiroth Welcome to the Rockstor community.

I don’t have a direct answer, other than to add a supported network card via for example the usb port, but a simpler work around might be to boot the usb key on another machine where the nic is supported and then pull down the update there. Then once that has completed and you’ve had a successfull reboot then shutdown and transferre the usb stick back to your intended machine. Or you could just install an nice fresh version of the latest Rockstor on the usb stick using the ‘donor’ machine and then once that install has gotten all of it’s update and again rebooted successfully you could try booting it ProLiant and hopefully the newer kernel and what not will deal better with that machines nic.

Hope that helps.

As per ext4 we employ the default CentOS btrfs install arrangement that currently uses ext4 only for the /boot partition. This is unaltered between kernel upgrade and so is quite usb stick friendly, and the main system root is btrfs (apart from the swap) and so is also quite usb friendly due to the cow nature of btrfs. Although we are due to re-visit our mount options for that volume as recent ‘best practice’ advise has changed on this front.

On a related note we do hope to soon rebase our iso release on a more recent CentOS and have the following issue to track this:

Hope that helps and let us know how you get on.

Silly question. Will a Wii USB NIC work? It is the only USB NIC I have. I found it on a server at a location I took over. The two built-in NICs worked, but some genius decided to use a Wii USB NIC! If that works, I’ll do it.

Also, would it be possible to plug a USB stick into my laptop (Gentoo GNU/Linux 64bit), partition it, format it, and install to those partitions?


No idea, could give it a go and see. All depends on if it’s supported in the kernel version you’ve currently got. If it does then your are away and can update and hopefully the newer kernel will end up supporting the build in nic. Or re-install on the target system of course.

If by that you mean could you install Rockstor to the USB stick once it was plugged into the laptop then yes, assuming the laptop successfully boots and runs the Rockstor install iso. But this is a risky business as you could inadvertently choose the wrong device and end up install Rockstor over the top of your Gentoo, which would of course be inconvenient. So if this is the only other machine available you could consider removing the laptop hdd/ssd: this may of course be impractical depending on how tricky this is on your laptop. Rockstor, akin to most linux installs, is pretty good about being moved from one machine to another so once installed on the usb stick could then be transferred back to the ProLiant.

Bit of a nuisance really but hopefully worth it if it works.

It’s worth noting that given Rockstor is essentially a customised CentOS it is not all that light so you will be better off using a fairly quick usb stick, ie I use a number of SanDisk Extreme usb 3.0 as they are like little ssd’s with a usb-to-sata bridge. You will probably be frustrated if using a regular slow stick as updates and some actions, as well as the install itself, can take ages. Potentially causing time outs even. A few forum members have noted a much improved experience once they moved from super slow cheap usb sticks to something a little more appropriate.

Hope I’ve understood your questions correctly there.

OK, on a whim I did an “ifconfig -a” and despite the installer claiming that I had no NIC, it sees it just fine as eno1. I configured it and it appears to be functioning. I did “yum update rockstor” and it tells me no packages are marked for updating. How do I update to 3.9.1 from 3.8.15?


OK, I tried logging into the web interface and got a prompt to accept the license, set the hostname, and create an account. I did, and it sat for thirty minutes doing nothing. I refreshed, tried again, and now it tells me that the account has already been created. How do I get past this login? I feel stuck.


Not quite sure what happened there as if the account already existed then it would tell you straight away. You could try again but with a different admin name. Nothing should take 30 mins apart from the install on a slow disk or an update, again on a slow disk. Although of course balances and scrubs can take a very long time.

Once you are past this then you should get a prompt to select your update channel that establishes the relevant repository.

By the way, internally Rockstor uses the network manager so you could use nmcli to set the network up.

Still cannot get this working. I am supposed to install this box tomorrow. That gives me a hair over 24hrs to get it up. If not, I have to start a Gentoo install.

I removed the old account via SSH using “userdel” and then tried the web interface again. No go. I MUST use this specific username because this is a company I am setting this up for. After removing the user and the home directory for the user, I tried again and got this.

          Traceback (most recent call last):
  File "/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py", line 40, in _handle_exception
  File "/opt/rockstor/src/rockstor/storageadmin/views/user.py", line 148, in post
  File "/opt/rockstor/src/rockstor/system/users.py", line 177, in useradd
    return run_command(cmd)
  File "/opt/rockstor/src/rockstor/system/osi.py", line 104, in run_command
    raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = ['/usr/sbin/useradd', '-s', '/bin/bash', '-m', 'reachfp']. rc = 1. stdout = ['']. stderr = ['useradd: cannot lock /etc/passwd; try again later.', '']



Tried again. Got a new error.

Houston, we've had a problem.

Unknown internal error doing a POST to /setup_user

No other info was there.


There shouldn’t be a problem with the user name “reachfp”. Had you already created that user during the install. If so that is the problem. All user creation and management is to be done after install.

You could always re-install and give it another go. Just make sure not to do any user stuff during initial install (in anaconda) except setting the root password and then there shouldn’t’ be any users ‘in the way’ for that first admin user creation. A full install doesn’t usually take more than a few 10’s of minutes max, unless your system disk is inappropriately slow.

I have reinstalled twice. Each time it takes about eight hours. Once done it only asks me for the root password. I cannot configure the NIC during install because the installer does not see it. I have no options during the normal install to create a user, so I am not doing that. Each time I try the web interface it fails one way or another. This is a real shame too, because I was hyped for RockStor (all of my company uses Gentoo with BTRFS file-systems) because it automates so much and it’s binary as opposed to having to build the updates.

So what can I do? Is it possible to do the web portion from the shell? I’ve been using Linux since the mid 90’s (on my Chromebook right now) and am not squeamish.


Cricky, that’s appauling. You are for sure using a very inappropriate and extremely slow system disk. Rockstor will never work properly with the system disk being that slow. Try using something a little less fantastically slow and you will get a great deal less frustration. That kind of speed is just going to trip up web time outs and the like.


When I say customized in the above quote that is not really cut down as much as re-branded. So only fairly fast and wear levelling usb sticks are appropriate, better still a straight hdd or better again an ssd. Rockstor uses the postgres database which is not a light thing all on it’s own. The Rockstor UI magic does have a cost.

Well done for persevering thus far though, but you really need to use something faster or find out where all the time is going as per:

Try, just for the time being, using a regular hdd for the install. You will be amazed at the improvement in install time. This transition took me a while at first but it’s just not worth even attempting Rockstor on regular usb sticks, they have to be fast and ideally hdd / ssd type speed.

Let us know how you get on.

I can’t. The one thing that has kept me from using Rockstor for so long is the unique inability to use the BTRFS disks for the OS, unlike everything else. The system has four SATA power adapters and all four are used. I cannot plug in any other disks, but since the Rockstor install guide said I could use a USB 2.0 flash disk I planned on that. I budgeted, invoiced, and setup for that. I can’t just go throw on the additional cost of a disk, and justifying a 500GB disk for a tiny 8GB install won’t fly. I can’t locate any more 8-16GB disks, so that’s out too.

The way I normally configure a NAS running Gentoo is to make a RAID10, make a subvolume for the OS and mount it, install Gentoo, and then leave the rest for subvolumes for individual shares. Works flawlessly, but I don’t run the atrocity known as systemd either. My guess is that you cannot boot BTRFS RAID with systemd. Am I right?

Now, all of that aside, is it possible to put the OS onto the RAID disks? I can use System Rescue CD or something for the initial setup. I just need a solution that doesn’t involve purchasing a another disk, another power supply, and using a fifth SATA cable. Actually, the fifth port MAY be shared with the eSATA port so that won’t work either since the external backup will be eSATA. What are my options?

OK, I found a 32GB USB3 flash disk laying around and used that. No issues, but how do I get it to 3.9.1? This is our trial of Rockstor to determine whether or not we keep using Gentoo or if we start using Rockstor. The client was not invoiced for an update plan. I have 3.9.1 on USB stick but because the installer is broken I had to use 3.8.15.