Upsrw username and password?

I have successfully set-up the UPS / NUT service, however I’d like to slightly modify one variable:
battery.runtime.low

When I run upsrw -s battery.runtime.low=240 ups@localhost it asks for my user and pass.
I have tried many different variations of my root pass, NUT user pass, and whatever is in upsd.users, but no dice.
I get ERR ACCESS-DENIED.

@aremiaskfa I’ll have a quick go at this one.

I seem to remember something about nut being picky about the user you address it via.

But from:
https://networkupstools.org/docs/man/ups.conf.html

the ignorelb entry has something on adding related settings manually into ups.conf:

override.battery.charge.low = 30
override.battery.runtime.low = 180

is their example. Maybe this would be a work around. You could also try using the nut user setup by Rockstor’s config. Take a look at what is established by the Rockstor config.

We have the following forum developer Wiki entry on our NUT workings here:

Network UPS Tools (NUT) - Rockstor’s implementation

Maybe that will have some useful pointers. It was written in our CentOS days but he mechanisms are the same, but I think we may have had to change some file locations to adapt to our new v4 OS base of openSUSE.

Hope that helps.

3 Likes