USB Install on Odroid H2


I’ve been messing around with Rockstor in a VM and, happy with the way it is working, I wanted to install it on my Ordroid H2 SBC (Intel).

Using the same ISO image I used to install on the VM, I created a USB installer with Etcher. When I boot the USB stick, I don’t get the familiar splash screen…I get the attached image instead and nothing else happens. :frowning: I’ve also tried using “dd” to create the installer as well as a different USB stick. The stick I’m using I’ve been able to use to install other distros as it happens.

Looking at the instructions, I see one set of instructions that suggest renaming the “isolinux” files/directories on the install media to “syslinux”, but official instructions have no mention of this. I’ve not tried renaming the files yet, since I haven’t worked out how to modify the file system that Etcher/dd creates

Has anyone come across this issue before?!


@Cloggs Welcome to the Rockstor community.

This looks like a nice project; I fancy having a go at a board like this myself some time. All I can suggest is that our installer kernel (default upstream CentOS) is just too old to work with some ‘special’ element of this CPU / board. However after initial install and consequent reboot we move to a much newer kernel. So if you could remove this nvme device on this board, I assuming that is destined to be you system drive, and place it in another more regular machine and then perform the Rockstor install and consequent reboot so that the installed system then boots to our much newer 4.12 kernel, then put the nvme back into the Odroid H2 and try booting then. I.e. do the install and initial reboot to the target system device on another computer and then move that system device back to the Odroid.

Major work around but if you have the facilities it may get you up and running. Otherwise you may be looking at kernel command line options to coax the old 3.* installer kernel into working on that hardware.

Do keep us updated on this one. Post our move to openSUSE we should have a much newer installer so this situation should be alleviated somewhat.

Hope that helps.

Hey @phillxnet, thanks…I’d really like to get this working since, out of all the NAS distros I’ve tested, Rockstor seems to be the only one that fits my needs (Samba AD integration actually seems to work out of the box without loads of messing around ).

Sadly, I have no means to plug the nvme device in to anything else right now…maybe some kind of USB adapter hooked up to the VM would do the job?

…or maybe I could install to another USB stick and do some kind of cloning post-install/reboot? Not sure if Rockstor installs to USB media?

As for coaxing the old 3.* installer kernel, I’m not sure I have the skillset to do the coaxing. However, if I’m able to find good instructions, I’m willing to give that a go.

Thanks for the response. :slight_smile:


Yes we do need to so some work there.

Yes me too. I see the SBC’s as quite an attractive target for Rockstor as it goes. But realy we have to stick to the Intel variants for the time being. But I’m gong to try and put time into some more powerful 64 bit ARM based variants but Intel first really.

Yes that’s possible, as long as you are careful re mapping devices. Making sure you pass the correct device through to the VM of course. So pass the USB stick to the VM as a raw block device then use the VM to install Rockstor onto that USB stick, reboot post install from the USB stick (using the VM) so you ensure the new kernel is in place. Them move USB stick to Odroid.

Yes. Also see our Minimum system requirements in the Quick start section of the docs. But note also that we have a proposed update to that doc section as follows:

which would change it to read as displayed in that link. Has a note re USB key choice. Basically only use fast USB keys. Regular ones are not going to cut it as you will get timeouts on the Web-UI and all sorts of consequent problems. Plus a very slow experience with the Web-UI generally even when it doesn’t actually time out.

We may get forum members chipping in with suggestions on this one.

Good Luck. Quite looking forward to playing with such devices once we have moved to openSUSE and intend then to try and provide image based install to make install much easier / quicker.