Using Samba to access Shares on Mac

Hello hello.

I’m a very new Rockstor user and I’m just trying to get a few of the basics setup but am running into a bit of trouble. Tried my best to find answers on my own but ran into a dead end. In Rockstor, I setup a new Share, made myself the Owner and set the Group membership to “users”, and connect using the macOS “Connect to Server” window (Cmd + K). However, when I enter my credentials, Rockstor seems to accept them as valid, but I get this error message:

There are no shares available or you are not allowed to access them on the server. Please contact your system administrator to resolve the problem.

This is the path I enter to connect to the server, so I’m wondering if maybe it’s trying to connect me to the root directory instead of the specific Share?

00%20PM

However I did try with IP_ADDRESS/Share-Folder and got the same result. I dunno, just scratching my head on this one. Any help would be greatly appreciated. Thanks.

1 Like

Hi @reid, and welcome to the community!

I wonder if it’s the specification of the smb protocol in the address you use that may be causing the issue here…
Last time I tried under macOS, I specified the IP address.directly or the hostname and it worked; see our docs on the matter for screenshots and more details:
https://rockstor.com/docs/interface/storage/file_sharing/samba_ops.html#from-mac-os

Alternatively, there may be some difference in macOS versions but let’s try the above first and take it from there.

4 Likes

Hey Flox, thanks so much for the reply. I tried it just using the IP address as well with no change. It allowed me to enter my credentials, then gave me the same error as above.

1 Like

Ok, thanks for the update. I will try the repeat the steps we have in the docs to make sure these instructions are still valid when I get a chance.
In the meantime, and to rule out anything related to the share setup, can you confirm you set the permission of your Rockstor share exported by Samba as described in the docs?

Sorry I can’t give you a proper answer at the moment; I’m hoping I’ll have some time to try in a few hours.

2 Likes

Ah, I’m dumb. I had the export set up incorrectly and it wasn’t allowing my user to access the Share. Thanks for the info and the documentation - appreciate your quick replies to all this!

4 Likes

Great!
Glad it was just a matter of configuration.

Cheers !

3 Likes