Using Transmission over OpenVPN - solution, testers wanted

I’ve added a Rock-on that I’d like to get some testing done with. It currently works for me, but I’m sure there’s folks out there with other VPN providers. Currently the Rock-on could do with a bit of documentation (especially in the Environment fields section), but a cursory glance over the original Docker container’s documentation should clear most things up.

I’d love to get some feedback, preferably on the pull request itself!

Edit: updated link to new PR.

I would like to test, especially if you will provide detailed setup assistance. I currently use Utorrent RSS auto downloader on a windows machine with btguard vpn saving to a share on a WDex4. I have a Rockstor machine set up and will be building a second for backups. I would like to use Transmission and lazy librarian as well as Couchpotato with my btguard vpn on these Rockstor machines but have not been able to get the rockons to communicate properly as far as shares let alone VPN.


I tried using this rock-on with my PIA account.

The magnetic link torrent i use to check the IP reported the VPN Address as it should.

But I could not download any torrents

On my third reinstall of Rockstor at the moment as I seem to trash things while trying to get rock-ons working.

The things i do to use a pile of drives and BTRFS for bit rot protection…

I’d have to take some time to get back into the whole Rock-on thing again - this has been working for me in the background for the last couple of months (with a caveat), and I’d still love to see more eye-balls on it and see what people run into. I’m a bit short on time, though, so apologies if I’m slow in responding. Things could take a couple of days for me to notice at first, let alone come up with a reply.

@kysdaddy I think your question is a bit broader than just this particular Rock-on - getting Rock-ons to work in general, complete with how to set up your shares, is a bit beyond this part; you might have more luck splitting that out as a separate question which’ll get more eyeballs.

@Carl_Banks can you define “could not download any torrents”? Does a torrent show up in Transmission? Does it show transfer? Are you able to take a peek at the logs by logging into your rockstor server and typing docker logs --tail 100 transmission-openvpn?

I would add a torrent file or magnetic link. They would show up in the torrent list. There would be zero activity (download/upload/connected peers…)

Currently can not get even that. I had to reinstall the whole shebang a few times.

Transmission - OpenVPN
Docker container running Transmission torrent client with WebUI while connecting to OpenVPN

Failed to install in the previous attempt. Here’s how you can proceed.
Check logs in /opt/rockstor/var/log for clues.
Install again.
If the problem persists, post on the Forum or email

There was a lot in the logs, so in my frustration I deleted them hoping to be able to see what is going on currently. Haven’t seen a new thing in the rockstor logs since.

So run I run your command I get:

[root@rockstor /]# docker logs --tail 100 transmission-openvpn
Error: No such container: transmission-openvpn

I think if I do another install and don’t allow any updates it will work, at least as wells as when I first posted about this.

But I’m kind of tired of testing the 3.9.1-16 branch and am thinking of taking a break until a more mature build is released to testers.

If I knew the Rock-ons I care about would work I’d pay for stable, but so far I’ve been to frustrated trying to get things to just work.

I had that too, occasionally, and it turned out to be the tunnel not being up. Restarting the Rock-on would solve it, and currently it has been 7 weeks or so since I’ve had to do it (which is a good thing, since restarting the Rock-on also resets Transmission’s settings - that’s still something to fix). Is it possible for you to run the container on a different machine? For me, it was helpful to test-drive the container on my laptop until I was sure it worked correctly(-ish) - then again, I have docker set up on that laptop, and I’m somewhat comfortable with it.

That’s odd, that means the whole container isn’t there at that moment. Then again, you did mention you deleted things.

I’m currently on 3.9.1-16 myself, and as they helpfully say, “It Works On My Machine”. The problem with troubleshooting this container is that it’s actually doing two jobs (which is a bit of an anti-pattern in the docker world), and VPNs are sometimes a pain in the behind to get working. I know that’s not really all that helpful to you at the moment, but hang in there. :slight_smile: Once things do start working, however, it’s all glorious. Let’s see if we can get you there.

You say you deleted containers and logs - I’m assuming you deleted the logs from the command line, but how did you delete the containers? There’s both the container itself (which is a docker affair) and the bit of database stuffing around it to keep Rockstor happy. Also, to keep me from telling you things you already know or asking things you have no way of knowing: what’s your knowledge / comfort level wrt docker and linux?

Thanks for the reply. FYI I have been able to get the shares and all working, now I have 3 of 4 rockons working. NZBGet Rock-on works with LazyLibrarian Rock-onto download NZB’s Transmission Rock-on works with LazyLibrarian Rock-on to download torrents. but I am unable to get the Transmission over OpnVPN working. I fail to grasp the “The container supports the LOCAL_NETWORK environment variable.” instructions. therefore cant access the webui I’m a newbie but earning every day

It is my understanding that this option allows you to access the webUI despite it being behind the VPN. Have a look at the container’s documentation for more details on that:

My knowledge is more limited than others here, but usually, you can set this option according to your network’s settings. It usually is LOCAL_NETWORK= or LOCAL_NETWORK=

I think I only deleted logs. I did try to uninstall and reinstall rock-ons from the web interface.

I moved back to ubuntu server. There are a lot of guides and was able to get deluge working with openvpn.

Thanks for offering to help. I got so frustrated I went back to what I knew. I started this project desiring something that was more like an appliance. FreeNAS was the goal, but hardware did not have enough RAM, and disks where not the same size so I needed BTRFS. Hence rockstor.

Hi there - I’ve been using this Rockon for a short period and seems to work well using Newshosting VPN. I find that it lacks some visibility into whether or not the VPN is up or down and the VPN details such as IP, etc. That would be a nice feature.

Can you tell me if the initial configuration settings can be changed? (PVN username/pass specifically)
Thanks for the good work.

Seems a search turns up this post: Exception while running command(['/usr/bin/hostnamectl', '--static']): [Errno 24] Too many open files - #3 by tjr that says leaving the webui open for too long will cause this.

hello, trying to use transmission over vpn but always get permission problems at beginning of download. i’ve created 2 shares for the purpose, with admin root, trans-vpn and trans-data but don’t know what else to do, thank you.

UPDATE: it seems that transmission could not create the directories needed inside the /data/ folder. I have then created from sftp the folders, with perm. 755 and now it works. Still cannot understand why this happens.