Warning: Repository 'Leap_15_2_Updates' appears to be outdated

I keep getting this error when running update command. Just wondering if there’s a fix for this. Thanks


@Emmanuel_perez Hello again.

Yes, this is likely due to Leap 15.2 now having reached EOL. Our first stable installer of the “Built on openSUSE” initiative was based on Leap 15.3.

So given you are still on 15.2 you can either:

1: reinstall using our installer which currently pre-installs the v4.1.0 rockstor rpm and it’s dependencies. And then import your pool/s and then apply you config save if you took and downloaded one before hand.
2: Distribution update in-place, and for that we have the following how-to:

"Distribution update from 15.2 to 15.3" https://rockstor.com/docs/howtos/15-2_to_15-3.html

You would be best to follow our instruction in the above how-to if you do take the update-in-place route as there were a number of repository changes between 15.2 and 15.3, both for us and for the upstream. Also note that you must first be running at least rockstor version 4.1.0-0 before you do an in-place update, as otherwise there is a (fixable) failure to start the rockstor services on first reboot.

See the v4.1.0-0 fix for this
Issue: https://github.com/rockstor/rockstor-core/issues/2335
Fix (pr): https://github.com/rockstor/rockstor-core/pull/2336

Also, if you are on the testing channel, DO NOT, go beyond v4.1.0-0 as we are about to start what will be a brand new (read broken for the time being) testing release phase.

Hope that helps and let us know how you get on.


Awesome! Thank you for the reply. Ive been wanting to reinstall Rockstor for a while. It all works out thanks!