Web Setup Not Working

I have just installed rockstor on an old PC I had lying around. I boot it up and install the OS. It all works fine until I try to get to the web post install setup. The console says to go to, but this doesn’t work. I ran sudo ip addr show and used that IP but it still did not work.

Any help is appreciated!

@vtallen Welcome to the Rockstor community.

Are you sure you are specifying https as http will not work. The Rockstor Web-UI is only available over https.
Also, after first install and on first boot, it can take a few minutes for the system to get setup. If you press the return key on the console it should update the message to reflect the ip: negating the need to login and indicating that the code that re-sets the console message has now been run. Soon there after the Web-UI should be available.

Let us know how you get on.

Thank you, that worked, I created a pool with all of my drives, then created a share and exported it with samba, but now it doesn’t show up on my network.

@vtallen Great, glad you got it sorted.

I’d suggest you start a new thread detailing what you did re the share creation and samba export / settings ie the workgroup etc and then people can chip in with ideas as to what it could be. I’d check you have the same workgroup on both the Rockstor and the client machines.