Windows 11 SMB Woes

Two identical W11 PCs on the same wired LAN. One works perfectly accessing shares, etc. The other displays the following:

NAS is visible in Explorer, with all shares showing. Clicking on some shares returns “not accessible” dialogue, while clicking on others asks for credentials. When entered, this dialog results:

Both computers have file sharing on, and “SMB Direct” is explicitly allowed in Windows firewall. The user that “works” is a RockStor admin, the other is a vanilla user. Not even admin credentials work on the problem machine.

I am at my wit’s end.

@HomeGrownPC welcome to the Rockstor community.

at the cmd line does net use happen to show one ore more shares from that NAS?

Other place to check is whether you have some cached credentials related to your NAS

Control Panel → Credential Manager

In my example (also on W11) I actually see credentials both for the IP-based access as well as for the hostname (depending on the moon phase I use either approach to access Rockstor) …

if you do have some entry (or entries) there, you can remove these, run the net use * /d for good measure (or instead of * put the \\server name\share there) and restart explorer.exe (that’s not always necessary … but as with all good windows fixes, when in doubt restart :slight_smile: ).

Out of curiousity, are you using the wsdd Rockon for discovering your Rockstor instance and its shares?


OK, net use showed connections to the three shares that had previously shown “not accessible.” I cleared those per your instructions, and the user was able to access their personal share (owned by them) but not those same three. When I clicked on them, they returned the “not accessible” dialog and reappeared in the “net use” list even though connection was not made. On the server side, permissions are set to READ. WRITE and EXECUTE are off for members of group USERS.

Access on both computers is done by setting up a desktop shortcut to “\servername”. . .works fine on both rigs to open a window displaying shared folders. On the “good” computer, all file and folder operations work normally through explorer. On the “bad” computer, access troubles as described above. . .everything normal for “owned” folder only.

TIA for your help.

Did you also find anything under the Credential Manager?

Single entry under “hostname” deleted for testing, no change

1 Like

did you run net use /d in an elevated command prompt? Non-elevated and elevated net use can’t see each others’ mapped connections (if some exist), but windows still accounts for them “together”.
Of course, it’s another stab in the dark. If you did run the above in an elevated prompt, run it again in non-elevated, and if you did not, then see whether there’s anything while you’re in an elevated command prompt.

Finally, in an elevated command prompt, you can also try to force the stop and restart of the workstation service, which will definitely sever some existing connections:

net stop workstation /y

and then

net start workstation

I assume, both W11s are patched/updated to the same, e.g. 23H2? Also, on both machines I assume, the SMBv1 is (by default) disabled. On Rockstor, did you put a version constraint into the smb (e.g. min smbv2. max smbv3)?

Your W11 account name on the problem computer does not happen to be the same as the user it’s trying to use to connect (e.g. as MS account and JohnnyAppleSeed as the Rockstor user? Though, that might not matter, if you can’t even access it from the problem machine using the root user.

Finally, are you using wsd (windows service discovery) to connect to Rockstor (able to use Rockstor host name) or are you using the explicit IP address of Rockstor?


Try use ROCK-ON Module called " Web Service Discovery For Windows Networks" this really works for me on Win Server 2012-2021 and Windows 7/8/10 and 11… I have no trouble so far… Try install " Web Service Discovery For Windows Networks"