Windows backup failing on 1 machine, working on another

Hey everyone,

at work we currently have two servers running Rockstor, one new-bought Dell R330 and one older machine (ca. 2006/07). To test both we were running the backup function of a Windows Server, which writes one file of about 1,8 TB to the file system.
On the new Dell server this was working perfectly.
But with the exact same Samba config the old server just can’t do this. The backup process always stops after a few GB, the strange thing is - this amount of GB increases every day.

The first backup failed after 2 GB, the second after 9 GB, the third attempt after 13 GB… the last time it copied 86 GB, which is still far away from the final 1,8 TB.

Additionally the logs are getting jammed with the following lines:

[2017/02/09 03:43:14.355770,  3] ../source3/smbd/smb2_write.c:212(smb2_write_complete_internal)
  smb2: fnum 11599362, file WindowsImageBackup/server/Backup 2017-02-09 000043/eff89441-777f-11e2-93e8-002590a77f0d.vhdx, length=65536 offset=0 wrote=65536
[2017/02/09 03:43:14.355894,  3] ../source3/lib/util.c:1183(fcntl_getlock)
  fcntl_getlock: fd 42 is returned info 2 pid 0

The log file is from 3:41 am to 3:43 am and contains 54.000 lines, just repeating the same as above. This is when the backup fails:

Any ideas why and what we can do to fix this? One possible problem source is that the Windows host and the old server are directly connected via LAN to lower the network load.

Thanks in advance!

Hi @der_eismann and welcome to Rockstor :slight_smile:

First request: can you post your smb.conf ? (guessing: had some custom socket options / tuning paramns on samba global ?)

Second request: can you try having same operation with log level = 10 in your samba [global] config ? this will provide further info/debug. Please remember to remove it after tests to avoid unrequired extra logs

Third request: nics speed? new Dell i suppose 10Gb nic card, older machine 1Gb

Last request: Win Server version (checking this going to suggest a better solution)


Hi @Flyer, thanks for the fast reply!


log level = 3
map to guest = Bad User
cups options = raw
log file = /var/log/samba/log.%m
printcap name = /dev/null
load printers = no
strict allocate = yes
max protocol = SMB2_02

workgroup = WORKGROUP

####BEGIN: Rockstor SAMBA CONFIG####
root preexec = "/opt/rockstor/bin/mnt-share backup"
root preexec close = yes
comment =
path = /mnt2/backup
browseable = yes
read only = no
guest ok = no
admin users = user
####END: Rockstor SAMBA CONFIG####

I will repeat the backup process tonight with log level = 10, have to wait because people are still working :slight_smile:

Both are using 1Gb NICs.

And the Hyper-V host is a Windows Server 2012.

1 Like

My suggestions:

why are you using max protocol = SMB2_02 ?!? Win 2012 fully supports SMB3, so let it! :smiley:

strict allocate = yes usually suggested to yes when having large files, but sometimes failing - try playing with this too

Finally, although I’m quite curious about this and will wait your new checks, Windows Server 2012 has NFS Client, why not using NFS instead of Samba?? :boom:

NFS vs Samba performance is like Hulk vs Ariel the little mermaid :wink:

If it was that easy…

But I will try to disable strict allocate.

I never worked with NFS, I usually read things like (source):

CIFS/SMB really should be your choice for Windows clients & servers - NFS can be very insecure without the hassle of Kerberos. Using SMB you get the standard Windows security model.

But if you think it can increase the performance I will look for some HowTos.

Didn’t know about that samba bug, that’s a shame. So you’re running Windows Server backup directly to samba share? uhmm having a local backup + data transfer ?? (ex. robocopy)

NFS: give it a shot
SMB secutiry vs NFS security: NFS share doesn’t fit with multiple users ( vs a samba share having ex. domain users), but it’s ok when having a “system share” like that one you’re using to save backups