Windows cannot access share

I followed all the steps given in the documentations and installed Rockstor, created pools, shares, and then created a samba share which i accesses as per given on this page --> http://rockstor.com/docs/samba_ops.html#from-a-windows-machine
Now I am able to view the share on windows in the Network folder
When I open UDDHAVLABDE computer, I see the share that I have created in Rockstor.

But, now when I try to open it, I receive this error

What is the problem and any solutions?

Looks like your Share have not the right access settings. Look in Rockstar under Shares, you can set the share from “root” owner to your RockStor account-settings, this should work. After that you should be able to access the share under windows with your credentials. At least this is what helped me. Maybe we should file an issue that the share-owner should always be the current Rockstar User.

Bernd

Already did that, still problem consists!

Might be helpful if you give us a screenshot of the share -> “access-control”-Tab.
You find it under System->Shares->Select your share->Access Control.

1 Like

Ok. You have to hit “Edit“ and change user group to the one your samba user is. Then check “write“ under “group“.
Or you check “write“ under “other“. But then anybody can write in your share.
Let us know if it works.

Still problem consists!

So what about your samba settings?
Same Workgroup?
Try to make the share guest-browsable. Maybe Show us a Screenshot of the samba share settings.

Edit: I forgot to ask you if you get the error message before or after you enter your credentials.

I don’t know about the workgroup. How do I check that?

Go to Services-> samba and set it to the same your client is in. Default is “Workgroup“
Set the share to not guest browsable.

Did it work after setting the workgroup?

Set share admin as nobody