WOL on Rockstor 4 (SuSE)

Hi, I try to activate WOL on my Rockstor server.
I could activate it in BIOS settings and also can activate it by using ethtool.
ethtool -s eth0 wol g
which sets Wake-on: from d (deactivated) to g (for wake on MagicPacket)

Unfortunately this is not set permanently and after reboot again d = deactivated.
As in Rockstor 4 build with SuSE Leap 15.2 NetworkManger is used to configure NIC, i’m searching where I can add the command /usr/sbin/ethtool -s eth0 wol g
Startscript or during shutown?

Does anybody already configured WOL in Rockstor 4 build?

best regards
Andreas

2 Likes

OK, solved via systemd / systemctl :slight_smile:
I created the following service file /etc/systemd/system/WOL-eth0.service

[Unit]

Description=Wake-on-LAN for eth0

Requires=network.target

After=network.target

[Service]

ExecStart=/usr/sbin/ethtool -s eth0 wol g

Type=oneshot

[Install]

WantedBy=multi-user.target

than enabled and started it
systemctl enable WOL-eth0
systemctl start WOL-eth0

After reboot Wake-on ist now set to g

Hope that helps, if anybody wants to use WOL too.

regards
Andreas

3 Likes