Yum updating - battle of the repos?

Below is the current output if I check for updates on my rockstor installation at the console. It looks like centos that rockstor is based on has a bunch of updates.

The question is, should these updates be run or not? The kernel is flagged for update to 3.10 but rockstor is currently on 4.2.5. Naturally this is because yum is configured for multiple repositories so 3.10 is coming from normal centos repos and 4.2.5 is coming from the rockstor repo.

Is the rockstor repo all inclusive such that the updates from the standard centos repo aren’t needed? If so I’d suggest disabling the standard repos in the next release.

If it isn’t all inclusive, is it safe to update from the centos repo as-is or do some exclusions need to be made? I see no point in updating the kernel to 3.10 for example but I don’t know if it would “hurt” to do so or if it would just take up space in the /boot but otherwise be harmless.


[root@san01 ~]# yum check-update
Loaded plugins: changelog, fastestmirror
Rockstor-Stable | 2.9 kB 00:00:00
rockstor | 2.9 kB 00:00:00
Loading mirror speeds from cached hostfile

NetworkManager.x86_64 1:1.0.6-27.el7 base
NetworkManager-glib.x86_64 1:1.0.6-27.el7 base
NetworkManager-libnm.x86_64 1:1.0.6-27.el7 base
NetworkManager-tui.x86_64 1:1.0.6-27.el7 base
PackageKit-glib.x86_64 1.0.7-5.el7.centos base
alsa-tools-firmware.x86_64 1.0.28-2.el7 base
at.x86_64 3.1.13-20.el7 base
authconfig.x86_64 6.2.8-10.el7 base
avahi.x86_64 0.6.31-15.el7 base
avahi-autoipd.x86_64 0.6.31-15.el7 base
avahi-libs.x86_64 0.6.31-15.el7 base
bash.x86_64 4.2.46-19.el7 base
bind-libs.x86_64 32:9.9.4-29.el7_2.1 updates
bind-libs-lite.x86_64 32:9.9.4-29.el7_2.1 updates
bind-license.noarch 32:9.9.4-29.el7_2.1 updates
bind-utils.x86_64 32:9.9.4-29.el7_2.1 updates
binutils.x86_64 base
biosdevname.x86_64 0.6.2-1.el7 base
boost-system.x86_64 1.53.0-25.el7 base
boost-thread.x86_64 1.53.0-25.el7 base
bzip2.x86_64 1.0.6-13.el7 base
bzip2-libs.x86_64 1.0.6-13.el7 base
ca-certificates.noarch 2015.2.4-71.el7 base
cairo.x86_64 1.14.2-1.el7 base
chkconfig.x86_64 1.3.61-5.el7 base
chrony.x86_64 2.1.1-1.el7.centos base
coreutils.x86_64 8.22-15.el7 base
cpio.x86_64 2.11-24.el7 base
cronie.x86_64 1.4.11-14.el7 base
cronie-anacron.x86_64 1.4.11-14.el7 base
cryptsetup-libs.x86_64 1.6.7-1.el7 base
cups-libs.x86_64 1:1.6.3-22.el7 base
curl.x86_64 7.29.0-25.el7.centos base
cyrus-sasl-gssapi.x86_64 2.1.26-19.2.el7 base
cyrus-sasl-lib.x86_64 2.1.26-19.2.el7 base
cyrus-sasl-plain.x86_64 2.1.26-19.2.el7 base
dbus.x86_64 1:1.6.12-13.el7 base
dbus-libs.x86_64 1:1.6.12-13.el7 base
dconf.x86_64 0.22.0-2.el7 base
device-mapper.x86_64 7:1.02.107-5.el7 base
device-mapper-libs.x86_64 7:1.02.107-5.el7 base
dhclient.x86_64 12:4.2.5-42.el7.centos base
dhcp-common.x86_64 12:4.2.5-42.el7.centos base
dhcp-libs.x86_64 12:4.2.5-42.el7.centos base
dmidecode.x86_64 1:2.12-9.el7 base
dracut.x86_64 033-360.el7_2 updates
dracut-config-rescue.x86_64 033-360.el7_2 updates
dracut-network.x86_64 033-360.el7_2 updates
elfutils-libelf.x86_64 0.163-3.el7 base
elfutils-libs.x86_64 0.163-3.el7 base
file.x86_64 5.11-31.el7 base
file-libs.x86_64 5.11-31.el7 base
filesystem.x86_64 3.2-20.el7 base
findutils.x86_64 1:4.5.11-5.el7 base
firewalld.noarch 0.3.9-14.el7 base
freeipmi.x86_64 1.2.9-7.el7 base
freetype.x86_64 2.4.11-11.el7 base
gdk-pixbuf2.x86_64 2.31.6-3.el7 base
git.x86_64 updates
glib-networking.x86_64 2.42.0-1.el7 base
glib2.x86_64 2.42.2-5.el7 base
glibc.i686 2.17-106.el7_2.1 updates
glibc.x86_64 2.17-106.el7_2.1 updates
glibc-common.x86_64 2.17-106.el7_2.1 updates
gobject-introspection.x86_64 1.42.0-1.el7 base
gperftools-libs.x86_64 2.4-7.el7 base
grep.x86_64 2.20-2.el7 base
grub2.x86_64 1:2.02-0.33.el7.centos.1 updates
grub2-tools.x86_64 1:2.02-0.33.el7.centos.1 updates
grubby.x86_64 8.28-17.el7 base
gsettings-desktop-schemas.x86_64 3.14.2-1.el7 base
gssproxy.x86_64 0.4.1-7.el7 base
gstreamer1.x86_64 1.4.5-1.el7 base
gstreamer1-plugins-base.x86_64 1.4.5-2.el7 base
gzip.x86_64 1.5-8.el7 base
harfbuzz.x86_64 0.9.36-1.el7 base
hwdata.x86_64 0.252-8.1.el7 base
initscripts.x86_64 9.49.30-1.el7 base
iproute.x86_64 3.10.0-54.el7 base
iprutils.x86_64 2.4.8-1.el7 base
iptables.x86_64 1.4.21-16.el7 base
iputils.x86_64 20121221-7.el7 base
irqbalance.x86_64 3:1.0.7-5.el7 base
iwl100-firmware.noarch base
iwl1000-firmware.noarch 1: base
iwl105-firmware.noarch base
iwl135-firmware.noarch base
iwl2000-firmware.noarch base
iwl2030-firmware.noarch base
iwl3160-firmware.noarch base
iwl3945-firmware.noarch base
iwl4965-firmware.noarch base
iwl5000-firmware.noarch base
iwl5150-firmware.noarch base
iwl6000-firmware.noarch base
iwl6000g2a-firmware.noarch base
iwl6000g2b-firmware.noarch base
iwl6050-firmware.noarch base
iwl7260-firmware.noarch base
jasper-libs.x86_64 1.900.1-29.el7 base
kernel.x86_64 3.10.0-327.el7 base
kernel-tools.x86_64 3.10.0-327.el7 base
kernel-tools-libs.x86_64 3.10.0-327.el7 base
kexec-tools.x86_64 2.0.7-38.el7 base
kmod.x86_64 20-5.el7 base
kmod-libs.x86_64 20-5.el7 base
kpartx.x86_64 0.4.9-85.el7 base
krb5-libs.x86_64 1.13.2-10.el7 base
krb5-workstation.x86_64 1.13.2-10.el7 base
lcms2.x86_64 2.6-2.el7 base
less.x86_64 458-9.el7 base
libICE.x86_64 1.0.9-2.el7 base
libSM.x86_64 1.2.2-2.el7 base
libX11.x86_64 1.6.3-2.el7 base
libX11-common.noarch 1.6.3-2.el7 base
libXext.x86_64 1.3.3-3.el7 base
libXft.x86_64 2.3.2-2.el7 base
libXpm.x86_64 3.5.11-3.el7 base
libXv.x86_64 1.0.10-2.el7 base
libaio.x86_64 0.3.109-13.el7 base
libbasicobjects.x86_64 0.1.1-25.el7 base
libblkid.x86_64 2.23.2-26.el7 base
libcap-ng.x86_64 0.7.5-4.el7 base
libcollection.x86_64 0.6.2-25.el7 base
libcurl.x86_64 7.29.0-25.el7.centos base
libdb.x86_64 5.3.21-19.el7 base
libdb-utils.x86_64 5.3.21-19.el7 base
libdhash.x86_64 0.4.3-25.el7 base
libdrm.x86_64 2.4.60-3.el7 base
libffi.x86_64 3.0.13-16.el7 base
libgcc.x86_64 4.8.5-4.el7 base
libgomp.x86_64 4.8.5-4.el7 base
libgsf.x86_64 1.14.26-7.el7 base
libgudev1.x86_64 219-19.el7 base
libidn.x86_64 1.28-4.el7 base
libini_config.x86_64 1.2.0-25.el7 base
libipa_hbac.x86_64 1.13.0-40.el7_2.1 updates
libldb.x86_64 1.1.20-1.el7 base
libmount.x86_64 2.23.2-26.el7 base
libnfsidmap.x86_64 0.25-12.el7 base
libnl3.x86_64 3.2.21-10.el7 base
libnl3-cli.x86_64 3.2.21-10.el7 base
libosinfo.x86_64 0.2.12-3.el7 base
libpath_utils.x86_64 0.2.1-25.el7 base
libpcap.x86_64 14:1.5.3-8.el7 base
libpciaccess.x86_64 0.13.4-2.el7 base
libpng.x86_64 2:1.5.13-7.el7_2 updates
libproxy.x86_64 0.4.11-8.el7 base
libref_array.x86_64 0.1.5-25.el7 base
libsecret.x86_64 0.18.2-2.el7 base
libsemanage.x86_64 2.1.10-18.el7 base
libsmbclient.x86_64 4.2.3-10.el7 base
libsoup.x86_64 2.48.1-3.el7 base
libssh2.x86_64 1.4.3-10.el7 base
libsss_idmap.x86_64 1.13.0-40.el7_2.1 updates
libsss_nss_idmap.x86_64 1.13.0-40.el7_2.1 updates
libstdc++.x86_64 4.8.5-4.el7 base
libtalloc.x86_64 2.1.2-1.el7 base
libtdb.x86_64 1.3.6-2.el7 base
libteam.x86_64 1.17-5.el7 base
libtevent.x86_64 0.9.25-1.el7 base
libtirpc.x86_64 0.2.4-0.6.el7 base
libuuid.x86_64 2.23.2-26.el7 base
libwbclient.x86_64 4.2.3-10.el7 base
libxcb.x86_64 1.11-4.el7 base
libxml2.x86_64 2.9.1-6.el7_2.2 updates
libxml2-python.x86_64 2.9.1-6.el7_2.2 updates
linux-firmware.noarch 20150904-43.git6ebf5d5.el7 base
logrotate.x86_64 3.8.6-7.el7_2 updates
lzo.x86_64 2.06-8.el7 base
m4.x86_64 1.4.16-10.el7 base
mariadb-libs.x86_64 1:5.5.44-2.el7.centos base
mesa-libEGL.x86_64 10.6.5-3.20150824.el7 base
mesa-libGL.x86_64 10.6.5-3.20150824.el7 base
mesa-libgbm.x86_64 10.6.5-3.20150824.el7 base
mesa-libglapi.x86_64 10.6.5-3.20150824.el7 base
microcode_ctl.x86_64 2:2.1-12.el7 base
mozjs17.x86_64 17.0.0-12.el7 base
net-snmp-libs.x86_64 1:5.7.2-24.el7 base
netatalk.x86_64 5:3.1.7-1.2.el7.centos rockstor
nfs-utils.x86_64 1:1.3.0-0.21.el7 base
nss.x86_64 3.19.1-18.el7 base
nss-sysinit.x86_64 3.19.1-18.el7 base
nss-tools.x86_64 3.19.1-18.el7 base
ntp.x86_64 4.2.6p5-22.el7.centos base
ntpdate.x86_64 4.2.6p5-22.el7.centos base
openldap.x86_64 2.4.40-8.el7 base
openssh.x86_64 6.6.1p1-22.el7 base
openssh-clients.x86_64 6.6.1p1-22.el7 base
openssh-server.x86_64 6.6.1p1-22.el7 base
openssl.x86_64 1:1.0.1e-51.el7_2.1 updates
openssl-libs.x86_64 1:1.0.1e-51.el7_2.1 updates
orc.x86_64 0.4.22-5.el7 base
pango.x86_64 1.36.8-2.el7 base
parted.x86_64 3.1-23.el7 base
pcre.x86_64 8.32-15.el7 base
perl.x86_64 4:5.16.3-286.el7 base
perl-Git.noarch updates
perl-Pod-Escapes.noarch 1:1.04-286.el7 base
perl-Test-Harness.noarch 3.28-3.el7 base
perl-libs.x86_64 4:5.16.3-286.el7 base
perl-macros.x86_64 4:5.16.3-286.el7 base
pixman.x86_64 0.32.6-3.el7 base
plymouth.x86_64 0.8.9-0.24.20140113.el7.centos base
plymouth-core-libs.x86_64 0.8.9-0.24.20140113.el7.centos base
plymouth-scripts.x86_64 0.8.9-0.24.20140113.el7.centos base
policycoreutils.x86_64 2.2.5-20.el7 base
poppler.x86_64 0.26.5-5.el7 base
poppler-glib.x86_64 0.26.5-5.el7 base
psmisc.x86_64 22.20-9.el7 base
pth.x86_64 2.0.7-23.el7 base
pygobject3-base.x86_64 3.14.0-3.el7 base
pytalloc.x86_64 2.1.2-1.el7 base
python.x86_64 2.7.5-34.el7 base
python-libs.x86_64 2.7.5-34.el7 base
python-pyudev.noarch 0.15-7.el7 base
python-setuptools.noarch 0.9.8-4.el7 base
python-six.noarch 1.9.0-2.el7 base
python-sssdconfig.noarch 1.13.0-40.el7_2.1 updates
python-urlgrabber.noarch 3.10-7.el7 base
rdma.noarch 7.2_4.1_rc6-2.el7 updates
realmd.x86_64 0.16.1-5.el7 base
rockstor-release.x86_64 3-8.10.el7 rockstor
rpcbind.x86_64 0.2.0-32.el7 base
rpm.x86_64 4.11.3-17.el7 base
rpm-build-libs.x86_64 4.11.3-17.el7 base
rpm-libs.x86_64 4.11.3-17.el7 base
rpm-python.x86_64 4.11.3-17.el7 base
rsync.x86_64 3.0.9-17.el7 base
rsyslog.x86_64 7.4.7-12.el7 base
samba.x86_64 4.2.3-10.el7 base
samba-client.x86_64 4.2.3-10.el7 base
samba-common.noarch 4.2.3-10.el7 base
samba-libs.x86_64 4.2.3-10.el7 base
samba-winbind.x86_64 4.2.3-10.el7 base
samba-winbind-clients.x86_64 4.2.3-10.el7 base
samba-winbind-modules.x86_64 4.2.3-10.el7 base
screen.x86_64 4.1.0-0.21.20120314git3c2946.el7 base
selinux-policy.noarch 3.13.1-60.el7 base
selinux-policy-targeted.noarch 3.13.1-60.el7 base
setup.noarch 2.8.71-6.el7 base
shared-mime-info.x86_64 1.1-9.el7 base
sos.noarch 3.2-35.el7.centos base
sqlite.x86_64 3.7.17-8.el7 base
sssd.x86_64 1.13.0-40.el7_2.1 updates
sssd-ad.x86_64 1.13.0-40.el7_2.1 updates
sssd-client.x86_64 1.13.0-40.el7_2.1 updates
sssd-common.x86_64 1.13.0-40.el7_2.1 updates
sssd-common-pac.x86_64 1.13.0-40.el7_2.1 updates
sssd-ipa.x86_64 1.13.0-40.el7_2.1 updates
sssd-krb5.x86_64 1.13.0-40.el7_2.1 updates
sssd-krb5-common.x86_64 1.13.0-40.el7_2.1 updates
sssd-ldap.x86_64 1.13.0-40.el7_2.1 updates
sssd-proxy.x86_64 1.13.0-40.el7_2.1 updates
sudo.x86_64 1.8.6p7-16.el7 base
systemd.x86_64 219-19.el7 base
systemd-libs.x86_64 219-19.el7 base
systemd-sysv.x86_64 219-19.el7 base
systemtap-runtime.x86_64 2.8-10.el7 base
teamd.x86_64 1.17-5.el7 base
totem-pl-parser.x86_64 3.10.5-1.el7 base
tracker.x86_64 1.2.6-3.el7 base
trousers.x86_64 0.3.13-1.el7 base
tuned.noarch 2.5.1-4.el7_2.1 updates
upower.x86_64 0.99.2-1.el7 base
usbutils.x86_64 007-5.el7 base
util-linux.x86_64 2.23.2-26.el7 base
virt-what.x86_64 1.13-6.el7 base
xfsprogs.x86_64 3.2.2-2.el7 base
xz.x86_64 5.1.2-12alpha.el7 base
xz-libs.x86_64 5.1.2-12alpha.el7 base
yum.noarch 3.4.3-132.el7.centos.0.1 base
yum-cron.noarch 3.4.3-132.el7.centos.0.1 base
yum-plugin-changelog.noarch 1.1.31-34.el7 base
yum-plugin-fastestmirror.noarch 1.1.31-34.el7 base
zlib.x86_64 1.2.7-15.el7 base
[root@san01 ~]# uname -a
Linux san01 4.2.5-1.el7.elrepo.x86_64 #1 SMP Tue Oct 27 12:32:38 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux

Great title @seijirou!

Short answer – yes, those updates should be run. Rockstor repos are complimentary to CentOS repos. Though we loose control by not channeling all updates through our repo, we don’t have the infrastructure to efficiently deliver all upstream updates to users around the world. Perhaps, we’ll get there some day.

This particular “update” from upstream is special becuase it’s the RHEL/CentOS 7.2 release updates. So, many packages were put in their “base” repo, such as the kernel. Normally, kernel updates from CentOS are distributed on “updates” repo and are excluded by Rockstor. But nothing is excluded from their “base” repo. Honestly, I did not know this is how they’d distribute. So, there’s a bit of a juggle.

You should update and afterwards, verify the python package version. It should be -18 and not -34. If you look at the yum config, you’ll see that we’ve excluded python updates from upstream-updates repo and -18’s come from ours. This is due to an incompatible backporting in -34. So, if you end up with -34 after the udpate, run an update again and it will reset itself.

Long story short, run the udpate, and run it again :slightly_smiling:

Alright update after running upgrade.

The upgrade pushed 3.10 kernel and as I suspected, on reboot it booted in to 3.10 so it required 2 reboots to get back to the 4.2.5 kernel.

Also python did update to -34 as you thought it might. Unfortunately simply running update again didn’t change anything and my guess is that even with the exclusion in place, by default yum isn’t going to replace a new version with an older one.

I worked around this by running yum downgrade python-2.7.5-18.el7_1.1.x86_64 python-libs-2.7.5-18.el7_1.1.x86_64 which reinstalled -18 from the rockstor repo.

After doing that, yum update does not show anything marked for update. so I think my box is good now.

Oh yes, you are on the stable channel right? The downgrade that you manually did happens automatically in the later code. Thanks for confirming that you are all set!

Thanks for this post I also updated to the latest updates for cent 7 and had python .34 version the downgrade worked for me as well