About to exceed share size

Just to confirm, in 3.9.2-57

Share sizes are not critical yet, are they?
(As per
http://rockstor.com/docs/shares-btrfs-subvolumes.html#share-size-enforcement-temporarily-disabled )

As long as there’s plenty of space in the pool I’m good?

(I tried to increase the Share size live but got an error with traceback,
so will wait until the processes copying data in finish. I see there are a few posts about that)

1 Like

here’s the traceback:

  Traceback (most recent call last):
  File "/opt/rockstor/src/rockstor/rest_framework_custom/generic_view.py", line 41, in _handle_exception
  File "/opt/rockstor/src/rockstor/storageadmin/views/share.py", line 247, in put
    share_pqgroup_assign(share.pqgroup, share)
  File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1240, in share_pqgroup_assign
    return qgroup_assign(share.qgroup, pqgroup, mnt_pt)
  File "/opt/rockstor/src/rockstor/fs/btrfs.py", line 1294, in qgroup_assign
    raise e
CommandException: Error running a command. cmd = /usr/sbin/btrfs qgroup assign 0/263 2015/31 /mnt2//DataPool. rc = 1. stdout = ['']. stderr = ['ERROR: unable to assign quota group: File exists', '']

@HarryHUK yes correct Share quotas are not enforced in Rockstor at present. I’ve had warnings showing shares are about 500% usage when I’d not bothered to set a proper share size and left it at 1GB or something like that, but it means nothing apart from an annoying alert in the GUI. As long as you know you have enough space in the pool all is good.

However I don’t remember experiencing errors when resizing shares like you mention. Assuming the share is not in the root pool?



It’s in the data pool. Tried to increase from 2.00 (TB) to 3.00, and then I tried 4.00. Same error both times.

Syncthing is uploading my home directory from my old desktop, and my readynas is copying backups into the same samba share, so it’s a bit busy, but that shouldn’t matter, should it?

Ok, I’d wait for that lot to do its stuff first. TBH I dont think it should be an issue, but one never knows…

Quotas were enabled for the pool…

I disabled them, and now I can’t re-enable them!
(Update: after a few attempts, they’re back on. seems I have to be patient…)

(Now I see that enabled was the default anyway, and this was probably not the problem…
As the help says, the share sizes are now reported as zero. At least the pool allocated size is still showing)

That’s good. Yes, patience can be a virtue with these things at times :slight_smile:

Further Update: now I managed to get quotas back on, I’ve managed to re-size the share (bigger)


Go figure, eh? Good result though.

If I have time tomorrow I might try the same in a VM…

Which Version are you using?

EDIT: Found the scroll wheel and saw your first post with version number :slight_smile:

1 Like

I was able to try this as best I could earlier this morning, but was unable to replicate the issues.

Quotas switched between enabled and disabled without issue (note it does take a few seconds and refreshes before this is reflected in the Dashboard widget re share usage dropping to zero when quota=disabled).
Was also able to increase and decrease Share size without error.
I was also running some random rsync data copy at the same time to replicate data activity (I dont use Syncthing).
So, unfortunately I cannot add anything to explain this I’m afraid.
I think you may have hit the nail on the head about patience :slight_smile: