After upgrade to Rockstor Leap 15.4, can't import shares from existing disk

I just upgraded to Rockstor Leap 15.4 using a new system drive (luckily).
It installed just fine but when I go to import the shares from my data disk, I get the following errors.

Houston, we’ve had a problem.
Failed to import any pool on device db id (3). Error: (Error running a command. cmd = /usr/sbin/btrfs
subvolume list -s /mnt2/share_it. rc = 1. stdout = [‘’]. stderr = [“ERROR: can’t perform the search:
Input/output error”, ‘’]).

Traceback (most recent call last):
File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 874, in _btrfs_disk_import
import_shares(po, request)
File “/opt/rockstor/src/rockstor/storageadmin/views/”, line 96, in import_shares
shares_in_pool = shares_info(pool)
File “/opt/rockstor/src/rockstor/fs/”, line 820, in shares_info
snap_idmap = snapshot_idmap(pool_mnt_pt)
File “/opt/rockstor/src/rockstor/fs/”, line 788, in snapshot_idmap
out, e, rc = run_command([BTRFS, “subvolume”, “list”, “-s”, pool_mnt_pt])
File “/opt/rockstor/src/rockstor/system/”, line 227, in run_command
raise CommandException(cmd, out, err, rc)
CommandException: Error running a command. cmd = /usr/sbin/btrfs subvolume list -s /mnt2/share_it.
rc = 1. stdout = [‘’]. stderr = [“ERROR: can’t perform the search: Input/output error”, ‘’]

To me, I think there is some sort of issue with the data disk.
I did test the whole drive with SpinRite and it shows no errors.
Is it likely some BTRS data issue?

Ummm, no expert here, but I have had the same problem and it was just I was trying to import from the wrong disk in a Raid-0 setup. I tried each disk and the last one listed worked…

Same thing happened on a Raid- 10 setup…


1 Like

I would also HIGHLY recommend upgrading to 5.0.9 in testing updates! Many problems resolved there!


I gave up on this install.
I installed 15.4 on another machine with 2 data disks and restored from an external NTFS volume I keep for just this kind of “emergency”.

So all is well, almost. I want to install 15.4 on the old server with the single 6TB drive. However, I need to get the data on this 6TB drive. I guess I’ll clean the drive and restore from my NTFS backup.

1 Like

FYI, I just downloaded and installed the latest Rockstor Leap 15.6 distribution from USB stick on both my NAS setups “without disconnecting anything”.

I had to re-enable the rockon stuff for F@H and redo that bit, but went without a hitch.

The only glitch was using the GUI, it seemed disk page would error out when refreshing until I rebooted… then all was well. It did this twice on two separate disk pool imports.

Now, both setups running perfectly with Testing Updates activated and both running Leap 15.6.

Happy dude here! My main NAS setup went from 4.1 to 5.0.9 without having to disconnect anything.

Pretty cool if you ask me!